summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNate Levesque2022-06-18 23:03:39 -0400
committerNate Levesque2022-06-18 23:03:39 -0400
commit29ad39fd5acd8f59c51aa55c108f793d2dc31d89 (patch)
tree94fb576a47b2bc1a8fecb174910f4d4e5735c47e /PKGBUILD
parent520e424130353861d446c4ee2bdf5a6cae4967f2 (diff)
downloadaur-29ad39fd5acd8f59c51aa55c108f793d2dc31d89.tar.gz
3.7.9 + patch + libxcrypt dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d67c577862a2..621f95aa7630 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Source : new application - https://forums.insynchq.com
pkgname=insync
-pkgver=3.7.7.50360
+pkgver=3.7.9.50368
pkgrel=1
_dist=buster
pkgdesc="An unofficial Google Drive and OneDrive client that runs on Linux, with support for various desktops"
@@ -21,6 +21,7 @@ depends=('adobe-source-code-pro-fonts'
'libglvnd'
'nss'
'xdg-utils'
+ 'libxcrypt'
)
optdepends=(
'lib32-libappindicator-gtk2: Required for tray icon in some configurations'
@@ -29,7 +30,7 @@ arch=('x86_64')
source=("http://s.insynchq.com/builds/${pkgname}_${pkgver}-${_dist}_amd64.deb"
'insync@.service'
'insync.service')
-sha256sums=('ae9f9a45625c4b3217bab25d378008d4e84fb07aefdf2a809803dcc6aa0e7ab0'
+sha256sums=('f9b42461ed71074549445ba1f9db699a42808ddffa70b504190cce15d2d01c1a'
'cf276c1dbf1592ea63a21c2d61c75f7ad6ec3b13e87b3aaa331e9c14799f4598'
'1432141539a6b3c5333631a2ee6696fab9bd2fe8770643bc670d95e4e96203e0')
package() {
@@ -46,4 +47,6 @@ package() {
mv ${pkgdir}/usr/lib/insync/libpangoft2-1.0.so.0{,.bak}
echo "-> Patching https://forums.insynchq.com/t/gui-is-broken-on-arch-for-3-7-7-with-workaround/18434"
mv ${pkgdir}/usr/lib/insync/libstdc++.so.6{,.bak}
+ echo "-> Patching https://forums.insynchq.com/t/workaround-for-libcrypt-so-1-issue-on-3-7-9-for-arch/18504"
+ ln -s /usr/lib/libcrypt.so.2 ${pkgdir}/usr/lib/insync/libcrypt.so.1
}