summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2018-12-13 00:16:58 -0500
committerTed Alff2018-12-13 00:16:58 -0500
commit207690ef34eaee59542e7e26b87abd96ab953f24 (patch)
tree555519410da977ac3e2d486da374fb26d7874001 /PKGBUILD
parent1e57d275ad982db8c664e88a4787aa498523e0d2 (diff)
downloadaur-207690ef34eaee59542e7e26b87abd96ab953f24.tar.gz
Patch for python 3 for nemo-python >= 3.9.0 -- I don't use insync, so don't know if this still works...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d688fa2eae75..468f44fd3bd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,21 @@
pkgname=insync-nemo
pkgver=1.3.12.36116
-pkgrel=1
+pkgrel=2
pkgdesc="Nemo integration for insync"
url="https://www.insynchq.com/downloads"
license=('custom:insync')
options=(!strip)
arch=('any')
depends=("insync" "nemo-python")
-makedepends=('gtk-doc')
-source=("${pkgname}-${pkgver}.deb::http://s.insynchq.com/builds/${pkgname}_${pkgver}-precise_all.deb")
-sha256sums=('e3b9ac6be0a2f0488aea05753c37b271763cc2f145ff860f5615a79bf2dc2113')
+source=("${pkgname}-${pkgver}.deb::http://s.insynchq.com/builds/${pkgname}_${pkgver}-precise_all.deb"
+ 'python3.patch')
+sha256sums=('e3b9ac6be0a2f0488aea05753c37b271763cc2f145ff860f5615a79bf2dc2113'
+ 'b67da8737af3b32ff392aa365ef6f1ce318c3a5c64d81819eac54f5a7ad6682e')
package() {
- tar -zxf "${srcdir}"/data.tar.gz -C "${pkgdir}"
+ cd "${srcdir}"
+ tar -zxf data.tar.gz
+ patch -Np1 -i ../python3.patch
+ cp -r usr "${pkgdir}"
}