summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDetMittens2018-01-21 11:37:11 +0000
committerDetMittens2018-01-21 11:37:11 +0000
commitc085b8fd23a9a2942d345b0882bf235469d13788 (patch)
tree84dfe0f186deff52be7356f661523966731518e6 /PKGBUILD
parent7f6f705ad205451a7c4e8cc7d7f6a3edfb4de577 (diff)
downloadaur-c085b8fd23a9a2942d345b0882bf235469d13788.tar.gz
Fix issue with driver trying to call libva-x11.so.1 by disabling support for VAAPI via X11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95c72b2d9cda..3894da40b222 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Contributer: uth 2.0.0 update
#
# Supported Platforms Features
-# Haswell (HSW) vp8enc
-# Bay Trail M (BYT) vp8enc
-# Broadwell (BRW) vp9dec vp9enc
-# Braswell (BSW) vp8enc vp9dec
+# Haswell (HSW) vp8enc
+# Bay Trail M (BYT) vp8enc
+# Broadwell (BRW) vp9dec vp9enc
+# Braswell (BSW) vp8enc vp9dec
+#
#
# The libva-intel-driver package isn't compiled with support for loading this driver
# so in order to use this driver's features with non hybrid codecs either
@@ -17,9 +18,10 @@ _gitroot="git+https://github.com/01org/intel-hybrid-driver.git"
_gitname=intel-hybrid-driver
_pkgver=2.0.0
pkgver=$_pkgver.r169.edead0c
-pkgrel=1
+pkgrel=2
pkgdesc='Libva support for partially hardware accelerated encode and decode on Haswell and newer'
-arch=('i686' 'x86_64')
+arch=('x86_64')
+install=${pkgname}.install
url='https://01.org/linuxmedia/vaapi'
license=('MIT')
depends=('libva' 'libcmrt')
@@ -39,7 +41,8 @@ prepare() {
build() {
cd ${srcdir}/${_gitname}
- ./configure --prefix=/usr
+ ./configure --prefix=/usr \
+ --disable-x11
make
}