summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-02-22 13:42:11 -0300
committerDaniel Bermond2018-02-22 13:42:11 -0300
commite9d28f21661961b49ef877373e5f0b2a925df40b (patch)
tree5a2e639e6dae2ff1b82d0fafe665f0188dbd3219 /PKGBUILD
parentdc2fcb84e0d27e57921b17fbd33eeaa202a26552 (diff)
downloadaur-e9d28f21661961b49ef877373e5f0b2a925df40b.tar.gz
Remove intel opencl patch (fixed by upstream)
Upstream now checks in cmake time if intel opencl is installed on the system and disables the building of the corresponding sample if it was not found, avoiding a compile error. References ---------- https://github.com/Intel-Media-SDK/MediaSDK/commit/cb58f7d7e9994ef6167ecadef9feaf023cf6481b
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD15
1 files changed, 2 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f20f82cb4ee7..91514a501b1b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
# Currently it will not be a mandatory makedepend.
pkgname=intel-media-sdk-git
-pkgver=1.2a.r49.g78bf771
-pkgrel=2
+pkgver=1.2a.r55.g22dae39
+pkgrel=1
pkgdesc='API to access hardware-accelerated video decode, encode and filtering on Intel platforms with integrated graphics (git version)'
arch=('x86_64')
url='https://github.com/Intel-Media-SDK/MediaSDK/'
@@ -26,8 +26,6 @@ makedepends=(
)
provides=('intel-media-sdk' 'libmfx')
conflicts=('intel-media-sdk' 'libmfx')
-source=('intel-media-sdk-detect-intel-opencl.patch')
-sha256sums=('689ebc270532c0e1e5132d39898ff2a93fe3483a5a2673aea396a24fc07ad24c')
prepare() {
# makepkg does not support cloning git-lfs repositories
@@ -43,15 +41,6 @@ prepare() {
cd "$pkgname"
fi
- for _patch in intel-media-sdk-detect-intel-opencl.patch
- do
- printf '%s\n' "Checking patch '${_patch}'"
- if patch -Np1 --dry-run -i "${srcdir}/${_patch}" >/dev/null
- then
- patch -Np1 -i "${srcdir}/${_patch}"
- fi
- done
-
# change plugins directory
if ! grep -q '^set(MFX_PLUGINS_DIR[[:space:]]/usr/lib64)$' CMakeLists.txt
then