summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2016-03-01 22:46:45 +0000
committerLeonidas Spyropoulos2016-03-01 22:46:45 +0000
commita1890f0f0d33e571e6ca7197ff1b0eb5cd3eaddb (patch)
treea7593113a07afeb27b3ef3c8ba0def88b2f7d0af /PKGBUILD
parent60ff06782c141e35b6ffd2f7904396888556d339 (diff)
downloadaur-a1890f0f0d33e571e6ca7197ff1b0eb5cd3eaddb.tar.gz
Update IntelliJ Idea Community EAP 16.145.184.1
Added an option to remove bundled JRE, upstream release.
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD21
1 files changed, 17 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e930472b4713..a3fe4f94ac22 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,20 @@
# Maintainer: Leonidas Spyropoulos <artafinde at gmail dot com>
# Based on Pycharm-EAP PKGBUILD by lots0logs
+### BUILD OPTIONS
+# Set these variables to ANYTHING that is not null to enable them
+
+# Remove bundled JRE - make sure you use your own, either through JAVA_HOME or
+# by setting the path to the JDK in ~/.IntelliJIdea16/config/idea.jdk
+_remove_bundled_jre=
+
+### Do no edit below this line unless you know what you're doing
+
pkgname=intellij-idea-ce-eap
_pkgname=idea-IC
-_buildver=144.4199.23
+_buildver=145.184.1
_pkgver=16
-_eap="False"
+_eap="True"
epoch=3
pkgver=16.${_buildver}
pkgrel=1
@@ -17,8 +26,8 @@ license=('Apache2')
depends=('java-environment' 'giflib' 'libxtst')
makedepends=('wget')
if [[ ${_eap} = "True" ]]; then
- source=("http://download.jetbrains.com/idea/ideaIC-${_buildver}-custom-jdk-linux.tar.gz")
- sha256sums=($(wget -q "${source}.sha256" && cat "ideaIC-${_buildver}-custom-jdk-linux.tar.gz.sha256" | cut -f1 -d" "))
+ source=("http://download.jetbrains.com/idea/ideaIC-${_buildver}.tar.gz")
+ sha256sums=($(wget -q "${source}.sha256" && cat "ideaIC-${_buildver}.tar.gz.sha256" | cut -f1 -d" "))
else
source=("http://download.jetbrains.com/idea/ideaIC-${_pkgver}-Preview.tar.gz")
sha256sums=($(wget -q "${source}.sha256" && cat "ideaIC-${_pkgver}-Preview.tar.gz.sha256" | cut -f1 -d" "))
@@ -27,6 +36,10 @@ fi
package() {
cd "$srcdir"
mkdir -p "${pkgdir}/opt/${pkgname}"
+ if [ -n "$_remove_bundled_jre" ]; then
+ msg "Removing bundled JRE..."
+ rm -rf "${srcdir}/idea-IC-${_buildver}/jre"
+ fi
cp -R "${srcdir}/idea-IC-${_buildver}/"* "${pkgdir}/opt/${pkgname}"
if [[ $CARCH = 'i686' ]]; then
rm -f "${pkgdir}/opt/${pkgname}/bin/libyjpagent-linux64.so"