summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2016-03-16 08:46:00 +0000
committerLeonidas Spyropoulos2016-03-16 08:46:00 +0000
commitbc043f0ca9f20274b023c9d78c1e3be868ec8855 (patch)
tree5477f0ff6108a8e92aa666e721fe10a1beef6c2c /PKGBUILD
parente687139a114c54b0c558d11d7dd5813733e795ab (diff)
downloadaur-bc043f0ca9f20274b023c9d78c1e3be868ec8855.tar.gz
Update IntelliJ Idea Community 2016.1-RC2
build version: 145.257.12 upstream release
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ecf816676fa0..0136fd549bbd 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,9 +12,10 @@ _use_no_jdk_archive=
pkgname=intellij-idea-ce-eap
_pkgname=idea-IC
-_buildver=145.256.33
+_buildver=145.257.12
_veryear=2016
_verrelease=1
+_verextra=RC2
pkgver=${_veryear}.${_verrelease}.${_buildver}
pkgrel=1
pkgdesc="Early access version of the upcoming version of Intellij Idea IDE (community version)"
@@ -24,13 +25,8 @@ url="http://www.jetbrains.com/idea/"
license=('Apache2')
depends=('java-environment' 'giflib' 'libxtst')
makedepends=('wget')
-if [ -n "$_use_no_jdk_archive" ]; then
- source=("http://download.jetbrains.com/idea/ideaIC-${_buildver}-no-jdk.tar.gz")
- sha256sums=($(wget -q "${source}.sha256" && cat "ideaIC-${_buildver}-no-jdk.tar.gz.sha256" | cut -f1 -d" "))
-else
- source=("http://download.jetbrains.com/idea/ideaIC-${_buildver}.tar.gz")
- sha256sums=($(wget -q "${source}.sha256" && cat "ideaIC-${_buildver}.tar.gz.sha256" | cut -f1 -d" "))
-fi
+source=("http://download.jetbrains.com/idea/ideaIC-${_veryear}.${_verrelease}-${_verextra}.tar.gz")
+sha256sums=($(wget -q "${source}.sha256" && cat "ideaIC-${_veryear}.${_verrelease}-${_verextra}.tar.gz.sha256" | cut -f1 -d" "))
package() {
cd "$srcdir"
@@ -40,6 +36,9 @@ package() {
rm -f "${pkgdir}/opt/${pkgname}/bin/libyjpagent-linux64.so"
rm -f "${pkgdir}/opt/${pkgname}/bin/fsnotifier64"
fi
+ if [ -n ${_use_no_jdk_archive} ]; then
+ rm -rf "${pkgdir}/opt/${pkgname}/jre"
+ fi
(
cat <<EOF
[Desktop Entry]