summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2016-03-13 20:42:32 +0000
committerLeonidas Spyropoulos2016-03-13 20:42:32 +0000
commite687139a114c54b0c558d11d7dd5813733e795ab (patch)
tree768a1717e84fab4c7bed1fc1eb43d267363174fa /PKGBUILD
parenta1890f0f0d33e571e6ca7197ff1b0eb5cd3eaddb (diff)
downloadaur-e687139a114c54b0c558d11d7dd5813733e795ab.tar.gz
Update IntelliJ Idea Community 2016.1
build version: 145.256.33 upstream release
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD32
1 files changed, 15 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3fe4f94ac22..ecf816676fa0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Leonidas Spyropoulos <artafinde at gmail dot com>
-# Based on Pycharm-EAP PKGBUILD by lots0logs
### BUILD OPTIONS
# Set these variables to ANYTHING that is not null to enable them
-# Remove bundled JRE - make sure you use your own, either through JAVA_HOME or
-# by setting the path to the JDK in ~/.IntelliJIdea16/config/idea.jdk
-_remove_bundled_jre=
+# Use the archive without the bundled JDK - make sure you use your own,
+# either through JAVA_HOME or by setting the path to the JDK
+# in ~/.IntelliJIdea2016.1/config/idea.jdk
+_use_no_jdk_archive=
### Do no edit below this line unless you know what you're doing
pkgname=intellij-idea-ce-eap
_pkgname=idea-IC
-_buildver=145.184.1
-_pkgver=16
-_eap="True"
-epoch=3
-pkgver=16.${_buildver}
+_buildver=145.256.33
+_veryear=2016
+_verrelease=1
+pkgver=${_veryear}.${_verrelease}.${_buildver}
pkgrel=1
pkgdesc="Early access version of the upcoming version of Intellij Idea IDE (community version)"
arch=('any')
@@ -25,21 +24,17 @@ url="http://www.jetbrains.com/idea/"
license=('Apache2')
depends=('java-environment' 'giflib' 'libxtst')
makedepends=('wget')
-if [[ ${_eap} = "True" ]]; then
+if [ -n "$_use_no_jdk_archive" ]; then
+ source=("http://download.jetbrains.com/idea/ideaIC-${_buildver}-no-jdk.tar.gz")
+ sha256sums=($(wget -q "${source}.sha256" && cat "ideaIC-${_buildver}-no-jdk.tar.gz.sha256" | cut -f1 -d" "))
+else
source=("http://download.jetbrains.com/idea/ideaIC-${_buildver}.tar.gz")
sha256sums=($(wget -q "${source}.sha256" && cat "ideaIC-${_buildver}.tar.gz.sha256" | cut -f1 -d" "))
-else
- source=("http://download.jetbrains.com/idea/ideaIC-${_pkgver}-Preview.tar.gz")
- sha256sums=($(wget -q "${source}.sha256" && cat "ideaIC-${_pkgver}-Preview.tar.gz.sha256" | cut -f1 -d" "))
fi
package() {
cd "$srcdir"
mkdir -p "${pkgdir}/opt/${pkgname}"
- if [ -n "$_remove_bundled_jre" ]; then
- msg "Removing bundled JRE..."
- rm -rf "${srcdir}/idea-IC-${_buildver}/jre"
- fi
cp -R "${srcdir}/idea-IC-${_buildver}/"* "${pkgdir}/opt/${pkgname}"
if [[ $CARCH = 'i686' ]]; then
rm -f "${pkgdir}/opt/${pkgname}/bin/libyjpagent-linux64.so"
@@ -66,6 +61,9 @@ EOF
mkdir -p "${pkgdir}/usr/share/applications/"
mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}/"
install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/"
+ for i in $(ls $srcdir/idea-IC-$_buildver/license/ ); do
+ ln -sf "${srcdir}/idea-IC-${_buildver}/license/$i" "${pkgdir}/usr/share/licenses/${pkgname}/$i"
+ done
ln -s "/opt/${pkgname}/bin/idea.sh" "${pkgdir}/usr/bin/idea-ce-eap"
}