summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorProgrammerGrammar2018-11-04 14:59:47 -0600
committerProgrammerGrammar2018-11-04 14:59:47 -0600
commit4b9e4fb0ec34901b144cea8cedaaec128f4778ab (patch)
tree288744084d30b60288df6028f52a8a7011d97c35 /PKGBUILD
parent4273c864b398f791fcd65ddd86e12da39c0989fe (diff)
downloadaur-4b9e4fb0ec34901b144cea8cedaaec128f4778ab.tar.gz
0.0.4 - trying to get install to run in path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b21fd1e48908..646e18e6ed84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
_npmname=interactive-diff-patch
-_npmver=0.0.3
-pkgname=interactive-diff-patch # All lowercase
-pkgver=0.0.3
+_npmver=0.0.4
+pkgname=nodejs-interactive-diff-patch # All lowercase
+pkgver=0.0.4
pkgrel=1
pkgdesc="Allows you to apply diff hunks one at a time and preview them on the command line. Requires diff and patch which are included with git."
arch=(any)
@@ -11,17 +11,15 @@ depends=('nodejs' 'npm')
optdepends=()
source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
noextract=($_npmname-$_npmver.tgz)
-sha1sums=(91ba80556a48691277015d3f22f591e1486196d6)
+sha1sums=(c8f42adaa79cbba789b129559d76115b75daf17a)
package() {
cd $srcdir
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p $_npmdir
cd $_npmdir
- npm install -g --user root --prefix "$pkgdir/usr" $_npmname@$_npmver
+ npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$_npmver
- # Non-deterministic race in npm gives 777 permissions to random directories.
- # See https://github.com/npm/npm/issues/9359 for details.
find "${pkgdir}"/usr -type d -exec chmod 755 {} +
}