summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHoward Cheung2020-07-02 22:03:43 +0800
committerHoward Cheung2020-07-02 22:03:43 +0800
commit441a52265e9f0a936a0d348201792062bd1a2cea (patch)
tree1076ca3feb0090c101c6038a0a29c53bc4213a0b /PKGBUILD
downloadaur-441a52265e9f0a936a0d348201792062bd1a2cea.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1832dac2d8fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Howard Cheung <mail@h-cheung.cf>
+# Contributor: Francisco Lopes <francisco@oblita.com>
+pkgname=interception-caps2esc-4modifiers-git
+_pname=interception-caps2esc
+pkgver=0.1.3.r1.g262d6e2
+pkgrel=1
+pkgdesc='caps2esc: transforming the most useless key ever in the most useful one, patch to use Ctrl as 4 modifiers'
+arch=('x86_64')
+license=(MIT)
+url='https://gitlab.com/h-cheung/caps2esc/'
+depends=('interception-tools')
+makedepends=('cmake' 'gcc')
+conflicts=('caps2esc' 'interception-caps2esc')
+provide=('caps2esc' 'interception-caps2esc')
+source=("$pkgname::git+https://gitlab.com/h-cheung/caps2esc/")
+md5sums=("SKIP")
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $srcdir/$pkgname
+ cmake -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
+}
+
+package() {
+ cd $srcdir/$pkgname/build
+
+ make DESTDIR="$pkgdir/" install
+}