summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrancisco Lopes2017-07-25 19:59:25 -0300
committerFrancisco Lopes2017-07-25 19:59:25 -0300
commit63e91c2012808c51c2ed485093aff2a28d1fe4b8 (patch)
tree6d77b20d215af2a4867eefd1729ebf3670abb7b8 /PKGBUILD
downloadaur-63e91c2012808c51c2ed485093aff2a28d1fe4b8.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9ed6eb6ba52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Francisco Lopes <francisco@oblita.com>
+pkgname=interception-caps2esc
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='caps2esc: transforming the most useless key ever in the most useful one'
+arch=('i686' 'x86_64')
+license=('MIT')
+url='https://gitlab.com/interception/linux/plugins/caps2esc'
+depends=('interception-tools')
+makedepends=('cmake' 'gcc')
+conflicts=('caps2esc')
+source=("https://gitlab.com/interception/linux/plugins/caps2esc/repository/archive.tar.gz?ref=v${pkgver}")
+md5sums=('a493a0c2a3ca056998e8eb0fd77f6a93')
+
+build() {
+ cd ${srcdir}/caps2esc-v${pkgver}-*
+ cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd ${srcdir}/caps2esc-v${pkgver}-*
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 444 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ make install
+}