summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGötz Christ2019-09-16 20:44:18 -0500
committerGötz Christ2019-09-17 19:12:18 -0500
commitdc7f3717dc3149b8e650fe5745eca660ec893ea6 (patch)
treefa79509b7f65e099079c9739b10d6f58a04ed05a /PKGBUILD
parentfeb5d6b3ad6876a95b6ed39857878eb45c70f123 (diff)
downloadaur-dc7f3717dc3149b8e650fe5745eca660ec893ea6.tar.gz
Use fork which comes with configurable deplay patches
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 26 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9befd0841eba..b591c404dce1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,35 @@
-# Maintainer: Francisco Lopes <francisco@oblita.com>
-pkgname=interception-caps2esc
-pkgver=0.1.3
-pkgrel=2
-pkgdesc='caps2esc: transforming the most useless key ever in the most useful one'
-arch=('x86_64')
-license=('MIT')
-url='https://gitlab.com/interception/linux/plugins/caps2esc'
-depends=('interception-tools')
-makedepends=('cmake' 'gcc')
-conflicts=('caps2esc')
-source=("$pkgname.tar.gz::https://gitlab.com/interception/linux/plugins/caps2esc/repository/archive.tar.gz?ref=v${pkgver}")
-md5sums=('014e1b3fcd7fd889aab876f22d550eb8')
+# Maintainer: Götz Christ <goetzchrist@gmail.com>
+# Contributor: Francisco Lopes <francisco@oblita.com>
+pkgname=interception-caps2esc-delay-git
+_realname=interception-caps2esc
+pkgver=0.1.3.r5.g3f9a39c
+pkgrel=1
+pkgdesc='caps2esc: transforming the most useless key ever in the most useful one - with delay patches'
+arch=(x86_64)
+license=(MIT)
+url="https://gitlab.com/mar04/caps2esc/"
+depends=(interception-tools)
+conflicts=(caps2esc interception-caps2esc)
+replaces=(interception-caps2esc)
+install=$pkgname.install
+source=("$pkgname::git+https://gitlab.com/mar04/caps2esc/"
+ "udevmon.yaml")
+md5sums=(SKIP
+ 44890a5f6c419c5eb6730636f3a6b535)
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
- cd ${srcdir}/caps2esc-v${pkgver}-*
+ cd $srcdir/$pkgname
cmake -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
cmake --build build
}
package() {
- cd ${srcdir}/caps2esc-v${pkgver}-*/build
-
+ cd $srcdir/$pkgname/build
make DESTDIR="$pkgdir/" install
+ install -D -m0644 $srcdir/udevmon.yaml "$pkgdir/usr/share/doc/$_realname/udevmon.example.yaml"
}