summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrancisco Lopes2017-12-13 21:10:16 -0200
committerFrancisco Lopes2017-12-13 21:10:16 -0200
commit3d6bce689ec1881c5a52e762f3977a5dc31543ac (patch)
treee3d368fe9a6ccf5207bcfd60970b8a7126c31e06 /PKGBUILD
downloadaur-3d6bce689ec1881c5a52e762f3977a5dc31543ac.tar.gz
0.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6932ad8a1930
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Francisco Lopes <francisco@oblita.com>
+pkgname=interception-hideaway
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='hideaway: a Interception Tools plugin to hide your mouse pointer'
+arch=('x86_64')
+license=('MIT')
+url='https://gitlab.com/interception/linux/plugins/hideaway'
+depends=('interception-tools')
+makedepends=('cmake' 'gcc')
+source=("https://gitlab.com/interception/linux/plugins/hideaway/repository/archive.tar.gz?ref=v${pkgver}")
+md5sums=('48ef1c714f6239fac5af2a7d30f38f56')
+
+build() {
+ cd ${srcdir}/hideaway-v${pkgver}-*
+ cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd ${srcdir}/hideaway-v${pkgver}-*
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 444 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ make install
+}