summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrancisco Lopes2019-01-28 03:25:44 -0200
committerFrancisco Lopes2019-01-28 03:25:44 -0200
commitb28852132974c824ca2df7395ab22dc72f7c64cb (patch)
tree77542690f36add29e3edebe574da3631ae8cb4ca /PKGBUILD
parent3d6bce689ec1881c5a52e762f3977a5dc31543ac (diff)
downloadaur-b28852132974c824ca2df7395ab22dc72f7c64cb.tar.gz
Fix out of source cmake generation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6932ad8a1930..7e5a63b0264f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
# Maintainer: Francisco Lopes <francisco@oblita.com>
pkgname=interception-hideaway
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='hideaway: a Interception Tools plugin to hide your mouse pointer'
arch=('x86_64')
license=('MIT')
url='https://gitlab.com/interception/linux/plugins/hideaway'
depends=('interception-tools')
makedepends=('cmake' 'gcc')
-source=("https://gitlab.com/interception/linux/plugins/hideaway/repository/archive.tar.gz?ref=v${pkgver}")
+source=("$pkgname.tar.gz::https://gitlab.com/interception/linux/plugins/hideaway/repository/archive.tar.gz?ref=v${pkgver}")
md5sums=('48ef1c714f6239fac5af2a7d30f38f56')
build() {
cd ${srcdir}/hideaway-v${pkgver}-*
- cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" -DCMAKE_BUILD_TYPE=Release
- make
+ cmake -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
}
package() {
- cd ${srcdir}/hideaway-v${pkgver}-*
-
- mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m 444 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd ${srcdir}/hideaway-v${pkgver}-*/build
- make install
+ make DESTDIR="$pkgdir/" install
}