summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGianluca Boiano2020-10-31 14:54:47 +0100
committerGianluca Boiano2020-10-31 14:54:47 +0100
commit8804d16e906760ff4943b1b9de88e9bdfd8a4577 (patch)
treead75f3a056785d6489c7be043abea4a905ca1e3f /PKGBUILD
parente08e119246c6cb9428457aa3b8a1fe14b72eb852 (diff)
downloadaur-8804d16e906760ff4943b1b9de88e9bdfd8a4577.tar.gz
iortcw-venom-mod: updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 815b90bf81a1..b8ed883116d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,19 +11,17 @@ depends=('iortcw-data')
makedepends=('unzip')
noextract=("$pkgname-$pkgver.zip")
source=("$pkgname-$pkgver.zip::https://www.moddb.com/downloads/mirror/173653/119/c90d40bdbeea743b5f31f401391f3ce4")
+_modpath="opt/iortcw/venom-mod"
-prepare() {
- # Unzipping with flattened paths
- unzip -jo $pkgname-$pkgver.zip -d paks
-}
package() {
- cd "$srcdir"/paks
- find . -iname "*.pk3" -exec install -Dm644 {} "$pkgdir/opt/iortcw/Venom\ Mod/"{} \;
- install -Dm644 autoexec.cfg "$pkgdir/opt/iortcw/Venom\ Mod/autoexec.cfg"
+ mkdir -p "${pkgdir}/${_modpath}"
+
+ # Unzipping with flattened paths
+ unzip -jo "$pkgname-$pkgver.zip" -d "${pkgdir}/${_modpath}"
# RealRTCW compatibility
mkdir -p "$pkgdir/opt/realrtcw"
- ln -sr /opt/iortcw/Venom\ Mod "$pkgdir/opt/realrtcw/Venom\ Mod"
+ ln -sr /${_modpath} "${pkgdir}/opt/realrtcw/venom-mod"
}
md5sums=('1eb9a668b79d3d3a675eb57af192e283')