summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxsmile2018-08-31 19:22:23 +0200
committerxsmile2018-08-31 19:22:23 +0200
commit3c51357bf4720e2357571bfff3d4cbb088b4feee (patch)
tree0b85a14803c1a2e26607e5fb6addc6afaadc9d31 /PKGBUILD
parent773ce3eeafaa314d9fc0ea1fea282bd5bf016d1a (diff)
downloadaur-3c51357bf4720e2357571bfff3d4cbb088b4feee.tar.gz
Add signature check
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 766a754ba47e..db12c782957d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,20 @@ arch=(x86_64)
url="https://trinity.iota.org/"
license=('Apache')
provides=(iota-trinity-wallet)
-source=()
options=('!strip')
-source_x86_64=("https://github.com/iotaledger/trinity-wallet/releases/download/desktop-v$pkgver/trinity-desktop-$pkgver.AppImage")
-md5sums_x86_64=('2dc09238410108da78f82606db932f27')
-sha512sums_x86_64=('675b710c6044cf9793c6afb16a95e7c13b208dc3ea6e7df472d28cea36f07f95ab9419e2f81000558523fa07598fb3353c06fd48e7e210b6decc87bc83826e75')
+source_x86_64=("https://github.com/iotaledger/trinity-wallet/releases/download/desktop-v$pkgver/trinity-desktop-$pkgver.AppImage"{,.asc})
+md5sums_x86_64=('2dc09238410108da78f82606db932f27'
+ 'SKIP')
+sha512sums_x86_64=('675b710c6044cf9793c6afb16a95e7c13b208dc3ea6e7df472d28cea36f07f95ab9419e2f81000558523fa07598fb3353c06fd48e7e210b6decc87bc83826e75'
+ 'SKIP')
source=("iota-trinity-wallet.desktop")
md5sums=('ebf2fc6a46b006ded903b6591c8f5897')
sha512sums=('eac7d8322ce501a0352d8998cd9fe53bd33c836f1fc9f1b775573bd741a2b402f66f82785f747b72702add15320e5cee8f62482bf2882176af57a9f5b3b0af0f')
+validpgpkeys=('466385BD0B40D9550F93C04746A440CCE5664A64')
+
prepare() {
# Extract Appimage
chmod +x "${srcdir}/trinity-desktop-$pkgver.AppImage"
@@ -45,4 +48,4 @@ package() {
# Link binary
install -dm755 "${pkgdir}/usr/bin"
ln -sr "${pkgdir}/opt/${pkgname}/trinity-desktop" "${pkgdir}/usr/bin/iota-trinity-wallet"
-} \ No newline at end of file
+}