summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorConrad Hoffmann2023-03-27 21:03:20 +0200
committerConrad Hoffmann2023-03-27 21:03:20 +0200
commit355bcba1fa4e84bb98f77481d5a1337f9d6155e3 (patch)
tree9bcf7dec03000b9aca919fda0dd9ccf6af476074 /PKGBUILD
parent3bfab9a987d302d73a6a419e7ce1bcbdc61a408e (diff)
downloadaur-355bcba1fa4e84bb98f77481d5a1337f9d6155e3.tar.gz
Update to 1.0.2, adapt to Gitlabs tarball changes
Thanks to Marcel Beyer for the inital patch.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4967853f78ef..be0e7cd9f349 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Conrad Hoffmann <ch@bitfehler.net>
pkgname=ipcalc-redhat
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
pkgdesc="Redhat's modernized ipcalc fork with IPv6 support"
arch=('x86_64')
@@ -11,16 +11,18 @@ conflicts=('ipcalc')
depends=('glibc')
makedepends=('meson' 'ruby-ronn')
source=("https://gitlab.com/ipcalc/ipcalc/-/archive/${pkgver}/ipcalc-${pkgver}.tar.gz")
-sha256sums=('60c21355fc74e6c8d4ef926bd992fcb36238d70d98aaa8e80f5b66375c9beee9')
+sha256sums=('d48d1f459703edfaf7b7f2f801be776065c3d0ca3fea2a79b2896c01df8b3f42')
+# Gitlab's tarballs now always contain a folder named after the commit :/
+_relcommit="4c4261a47f355946ee74013d4f5d0494487cc2d6"
build() {
- cd "$srcdir/ipcalc-$pkgver"
+ cd "$srcdir/ipcalc-$_relcommit"
meson setup build -Duse_maxminddb=disabled -Duse_geoip=disabled
ninja -C build
}
package() {
- cd "$srcdir/ipcalc-$pkgver"
+ cd "$srcdir/ipcalc-$_relcommit"
install -m755 -Dt "${pkgdir}/usr/bin/" build/ipcalc
install -m644 -Dt "${pkgdir}/usr/share/licenses/ipcalc/" COPYING
install -m644 -Dt "${pkgdir}/usr/share/man/man1/" build/ipcalc.1