summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkhai96_2019-03-15 19:02:22 +0700
committerkhai96_2019-03-15 19:02:22 +0700
commit1f0a6aa81070d0b15aceb4053a2359f06414fd73 (patch)
treef5eb07f6f903d6b96cab74e5c6ea0e9c79e0e840 /PKGBUILD
parentfed07dbab0e9eb6795f7bd8ef025a9120553c5fa (diff)
downloadaur-1f0a6aa81070d0b15aceb4053a2359f06414fd73.tar.gz
Use reusable environment variables
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a1021d5b8f4..09a973acbb04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,19 @@
pkgname=code-server
pkgver=1.32.0_282
-pkgrel=1
+pkgrel=2
pkgdesc="Run VS Code on a remote server"
arch=('x86_64')
url="https://github.com/codercom/code-server"
license=(MIT)
-source=(https://github.com/codercom/code-server/releases/download/${pkgver//_/-}/code-server-${pkgver//_/-}-linux-x64.tar.gz)
+_ghtag=${pkgver//_/-}
+_dirname=code-server-${_ghtag}-linux-x64
+source=(https://github.com/codercom/code-server/releases/download/${_ghtag}/${_dirname}.tar.gz)
sha512sums=(SKIP)
options=('!strip')
package() {
- cd "$srcdir/code-server-${pkgver//_/-}-linux-x64"
+ cd "$srcdir"/${_dirname}
install -Dm755 code-server "$pkgdir"/usr/bin/code-server
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE