summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2020-06-30 10:52:30 -0400
committergraysky2020-06-30 10:52:30 -0400
commit28e9131cc6f02c0503095d450ade904b69d48fd4 (patch)
tree282e27041bd4de684bdd1a4712e7f19e213a2e4e /PKGBUILD
downloadaur-28e9131cc6f02c0503095d450ade904b69d48fd4.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e50731ab39c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+
+pkgname=iphonebackuptools
+_commit=c5573a3e5446ea420a56d2477ef78550cee224fb
+_short=78
+# work around until upstream versions
+# https://github.com/richinfante/iphonebackuptools/issues/68
+pkgver=1.$_short
+pkgrel=1
+pkgdesc="extract"
+arch=('any')
+url="https://github.com/richinfante/iphonebackuptools"
+license=('MIT')
+depends=('nodejs' 'sqlite')
+makedepends=('npm' 'python')
+source=(
+https://github.com/richinfante/iphonebackuptools/archive/$_commit.tar.gz
+)
+sha256sums=('6cc52d2fe0b09a5b5fa8f9f80f4de77d9cc7dbf130057432a7267c9093372828')
+
+package() {
+ npm install -g --user root --prefix "$pkgdir"/usr "$srcdir/$_commit.tar.gz"
+
+ # Fix permissions
+ find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
+ chown -R root:root "${pkgdir}"
+}