summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJianqiu Zhang2021-08-02 23:25:31 +0800
committerJianqiu Zhang2021-08-02 23:25:31 +0800
commit609e1ffbcc03aaabe4750055941ef998ea3ca0a5 (patch)
tree962c889bd6191af6431bc94bb756304395edfe7f /PKGBUILD
parentde4c6808458c412160c1883347560ed08d50ed58 (diff)
downloadaur-ipmctl-git.tar.gz
Fix git apply patch
Signed-off-by: Jianqiu Zhang <zhangjianqiu13@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53869791f31e..76c139bcdbc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Jianqiu Zhang <void001@archlinuxcn.org>
pkgname=ipmctl-git
-pkgver=v02.00.00.3871.r2.g9c576e93
+pkgver=v02.00.00.3871.r1.gafa307c8
pkgrel=1
pkgdesc="util for configuring and managing Intel Optane DC persistent memory modules (DCPMM)."
arch=('x86_64')
url="https://github.com/intel/ipmctl"
license=(GPL3)
depends=("ndctl")
-makedepends=("cmake" "git" "python3" "ndctl")
+makedepends=("cmake" "git" "python3" "ndctl" "patch")
source=(
${pkgname}::git+https://github.com/intel/ipmctl
os_mkdir_for_gcc_11.patch
@@ -27,7 +27,7 @@ prepare()
echo "Applying the patch to fix gcc_11 compatibility issue."
cp os_mkdir_for_gcc_11.patch "$srcdir/$pkgname"
cd "$srcdir/$pkgname"
- git am os_mkdir_for_gcc_11.patch
+ git apply os_mkdir_for_gcc_11.patch
}
build() {