summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJianqiu Zhang2021-08-02 22:02:55 +0800
committerJianqiu Zhang2021-08-02 22:02:55 +0800
commitd6743ce170597597342dedef9a2010ea8e5fba53 (patch)
tree872ae514b1c61b81d9f947a20a3f2fd5578444ad /PKGBUILD
parent0a521b720df3bd6443b23fe29a697eb824502de5 (diff)
downloadaur-d6743ce170597597342dedef9a2010ea8e5fba53.tar.gz
Temporary solution for patching ipmctl's os_mkdir function
Signed-off-by: Jianqiu Zhang <zhangjianqiu13@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0330f1a168d8..53869791f31e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jianqiu Zhang <void001@archlinuxcn.org>
pkgname=ipmctl-git
-pkgver=v02.00.00.3673.r14.gc9a426c7
+pkgver=v02.00.00.3871.r2.g9c576e93
pkgrel=1
pkgdesc="util for configuring and managing Intel Optane DC persistent memory modules (DCPMM)."
arch=('x86_64')
@@ -9,8 +9,12 @@ url="https://github.com/intel/ipmctl"
license=(GPL3)
depends=("ndctl")
makedepends=("cmake" "git" "python3" "ndctl")
-source=(${pkgname}::git+https://github.com/intel/ipmctl)
-md5sums=('SKIP')
+source=(
+ ${pkgname}::git+https://github.com/intel/ipmctl
+ os_mkdir_for_gcc_11.patch
+)
+md5sums=('SKIP'
+ '64811bb8558e36916502141f4eefce9c')
pkgver()
{
@@ -20,7 +24,10 @@ pkgver()
prepare()
{
- echo "prepare()"
+ echo "Applying the patch to fix gcc_11 compatibility issue."
+ cp os_mkdir_for_gcc_11.patch "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname"
+ git am os_mkdir_for_gcc_11.patch
}
build() {