summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDonald Webster2019-01-11 09:25:37 -0800
committerDonald Webster2019-01-11 09:25:37 -0800
commit512f4ff1d60a9d466eaf73f84b89681cde31869a (patch)
tree3d830c90750bd75ac2b56e3fd40dabe6b4491353 /PKGBUILD
parent0deff7cf82f3334fb0c14c13bf2b1aeca2ab6d47 (diff)
downloadaur-512f4ff1d60a9d466eaf73f84b89681cde31869a.tar.gz
Remove i686 support, simplify PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 4 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ffd130be005..ce61a51143c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,21 @@
pkgname=ipmiview
pkgver=2.14.0
-_pkgname=IPMIView
-_pkgrev=180213
-_pkgver=${_pkgver}_${_pkgrev}
+_pkghash=180213
pkgrel=2
pkgdesc="Supermicro IPMI tool"
makedepends=('tar')
depends=("glibc" "java-runtime=8")
-arch=('x86_64' 'i686')
-if [ "${CARCH}" = "x86_64" ]; then
- _pkgarch=_x64
-else
- _pkgarch=
-fi
+arch=('x86_64')
license=('custom:"Super Micro Computer"')
url="http://www.supermicro.com/products/nfo/ipmi.cfm"
source=("ipmiview.desktop")
-source_i686=("https://www.supermicro.com/wftp/utility/IPMIView/Linux/${_pkgname}_${pkgver}_build.${_pkgrev}_bundleJRE_Linux.tar.gz")
-source_x86_64=("https://www.supermicro.com/wftp/utility/IPMIView/Linux/${_pkgname}_${pkgver}_build.${_pkgrev}_bundleJRE_Linux_x64.tar.gz")
+source_x86_64=("https://www.supermicro.com/wftp/utility/IPMIView/Linux/IPMIView_${pkgver}_build.${_pkghash}_bundleJRE_Linux_x64.tar.gz")
sha256sums=('41d5fa089912ee10d476a0f6aa3c12765861c1a71cf4f811efaf2e47c4ce9351')
sha256sums_x86_64=('90f08a8ccb38b4ccc048010dd93f73cc3360cc259331d08b589a567d2a17e2f2')
-sha256sums_i686=('37b6d1deb21960a75b077b6b87c640c211276dbc0fc8f217cf48dfba460c918b')
package() {
- cd ${srcdir}/${_pkgname}_${pkgver}_build.${_pkgrev}_bundleJRE_Linux${_pkgarch}
+ cd ${srcdir}/IPMIView_${pkgver}_build.${_pkghash}_bundleJRE_Linux_x64
# Remove bundled jre
rm -rf jre/