summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2017-11-13 15:41:39 +0700
committerKonstantin Shalygin2017-11-13 15:41:39 +0700
commitf77dec8e4559bc5a6d470c1b9973f53007a9a8f5 (patch)
treea773ee6130b005c020e21eea52a26500756c1cac /PKGBUILD
parentdbc53ae03fd518dcbb91da2d004bf20a910efe99 (diff)
downloadaur-f77dec8e4559bc5a6d470c1b9973f53007a9a8f5.tar.gz
Allow to define linux_custom package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59b660ce7452..6d524b65a15c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,8 @@ makedepends=('git' 'libtool' 'gcc' 'gzip' 'gawk' 'sed')
source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
install="${pkgname}.install"
-_kernver="`pacman -Ql linux| awk '/(\/modules\/)([0-9.-])+-ARCH\/$/ {print $2}'`"
+_linux_custom="ARCH"
+_kernver="`pacman -Ql linux| awk '/(\/modules\/)([0-9.-])+-'${_linux_custom}'\/$/ {print $2}'`"
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -23,6 +24,7 @@ pkgver() {
}
build() {
+ echo ${_kernver}
cd "${srcdir}/${pkgname}"
make KERNEL_DIR="${_kernver}build"
}