summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2018-08-07 20:26:41 +0700
committerKonstantin Shalygin2018-08-07 20:26:41 +0700
commit0bc16da012b71b2adb8bac88b11e57a07bdb6b81 (patch)
tree05155b9b6db6c3794f116b40217d324a326a53b7 /PKGBUILD
parentf21891ea56e5e764dd094c16413bd4126cea9035 (diff)
downloadaur-0bc16da012b71b2adb8bac88b11e57a07bdb6b81.tar.gz
Allow to define custom linux_localversion.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 021fee31cb7f..e8d7e12586c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,16 @@ pkgdesc='nDPI as netfilter extension.'
arch=('any')
url='https://github.com/vel21ripn/nDPI'
license=('GPL')
-depends=('linux' 'iptables' 'conntrack-tools')
-makedepends=('git' 'libtool' 'gcc' 'gzip' 'gawk' 'sed')
+depends=('iptables')
+makedepends=('git')
source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
install="${pkgname}.install"
+# define 'lts' for linux-lts package
_linux_custom="ARCH"
-_kernver="`pacman -Ql linux| awk '/(\/modules\/)([0-9.-])+-(.*)-'${_linux_custom}'\/$/ {print $2}'`"
+# define '-lts' for linux-lts package
+_linux_localversion=""
+_kernver="`pacman -Ql linux${_linux_localversion} | awk '/(\/modules\/)([0-9.-])+-(.*)-'${_linux_custom}'\/$/ {print $2}'`"
pkgver() {
cd "${srcdir}/${pkgname}"