summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2017-11-13 15:42:18 +0700
committerKonstantin Shalygin2017-11-13 15:42:18 +0700
commit26b187bbf20e02b1f8859b4359accb83ef3671a9 (patch)
tree19f8b942baba6b0077bdce5fa163889be4b3c3b5 /PKGBUILD
parent616955c5298d16256a058aef94f2fd9d16a759e2 (diff)
downloadaur-26b187bbf20e02b1f8859b4359accb83ef3671a9.tar.gz
Allow to define linux_custom package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0e03e757fdd..6f76bb3a53c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Shalygin Konstantin <k0ste@k0ste.ru>
pkgname='ipt_ndpi'
-pkgver=1.2_1.7.0.netfilter.233.64bc701
+pkgver=1.2_1.7.0.netfilter.234.0670f78
pkgrel=1
pkgdesc='nDPI as netfilter extension.'
arch=('any')
@@ -13,7 +13,8 @@ makedepends=('git' 'libtool' 'gcc' 'gzip' 'gawk' 'sed')
source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
install="${pkgname}.install"
-_kernver="`pacman -Ql linux| awk '/(\/modules\/)([0-9.-])+-ARCH\/$/ {print $2}'`"
+_linux_custom="ARCH"
+_kernver="`pacman -Ql linux| awk '/(\/modules\/)([0-9.-])+-'${_linux_custom}'\/$/ {print $2}'`"
pkgver() {
cd "${srcdir}/${pkgname}"