summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2017-09-06 16:13:17 +0700
committerKonstantin Shalygin2017-09-06 16:13:17 +0700
commitf3a91142774247c0a3ede03e49006e8496f50845 (patch)
treed91169fd55c0b01c1920afeae630b236618c5299 /PKGBUILD
parent5fd84ddd00274b384b408ac7edae557abd4d606f (diff)
downloadaur-f3a91142774247c0a3ede03e49006e8496f50845.tar.gz
Added patch for compile on 4.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4609c3b82b03..f5312174bc3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,10 @@ url='https://github.com/vel21ripn/nDPI'
license=('GPL')
depends=('linux' 'iptables' 'conntrack-tools')
makedepends=('git' 'libtool' 'gcc' 'gzip' 'gawk' 'sed')
-source=("${pkgname}::git+${url}")
-sha256sums=('SKIP')
+source=("${pkgname}::git+${url}"
+ "nDPI_netfilter_Linux_4.13.patch")
+sha256sums=('SKIP'
+ 'bb19cc451a7ab99507e41d65c4a5ba5d258e64d4a009afbab2d56bbfe16fd344')
install="${pkgname}.install"
_kernver="`pacman -Ql linux| awk '/(\/modules\/)([0-9.-])+-ARCH\/$/ {print $2}'`"
@@ -27,6 +29,8 @@ pkgver() {
prepare() {
cd "${srcdir}/${pkgname}"
+ patch -p1 -i "${srcdir}/nDPI_netfilter_Linux_4.13.patch"
+
./autogen.sh
}