summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2019-11-08 11:12:53 +0700
committerKonstantin Shalygin2019-11-08 11:12:53 +0700
commitf8d0bf54cafa516efa42e791f0e7a3fada63ec82 (patch)
tree1c48fb690ff2154b3b0a7354c450c8c728c09e9d /PKGBUILD
parent66fa1a8d86635fa4263827435ed8ac999144dc77 (diff)
downloadaur-f8d0bf54cafa516efa42e791f0e7a3fada63ec82.tar.gz
Fixed regex for 5.3+ Arch Kernels.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68e50010ba3a..93fb707d5acd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Shalygin Konstantin <k0ste@k0ste.ru>
pkgname='ipt_ndpi'
-pkgver=1.2_2.8.0.1501.56d8788
+pkgver=1.2_2.8.0.1530.8bd3384
pkgrel=1
pkgdesc='nDPI as netfilter extension.'
arch=('any')
@@ -12,11 +12,9 @@ depends=('iptables')
makedepends=('git')
source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
-# define 'lts' for linux-lts package
-_linux_custom="ARCH"
# define '-lts' for linux-lts package
-_linux_localversion=""
-_kernver="`pacman -Ql linux${_linux_localversion} | awk '/(\/modules\/)([0-9.-])+-(.*)-'${_linux_custom}'\/$/ {print $2}'`"
+_linux_custom=""
+_kernver="`pacman -Ql linux${_linux_custom} | awk '/(\/modules\/)([0-9.-])+-(.*)'${_linux_custom}'\/$/ {print $2}' | head -n1`"
pkgver() {
cd "${srcdir}/${pkgname}"