summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorasm0dey2018-11-11 23:43:09 +0300
committerasm0dey2018-11-11 23:43:09 +0300
commitcebf289244ce9ee02d05c6a84ab4e5e677204b5d (patch)
tree052d2b3c740517bc24a463be463ddb71f3771ec2 /PKGBUILD
downloadaur-cebf289244ce9ee02d05c6a84ab4e5e677204b5d.tar.gz
Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1260230f9fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: asm0dey <pavel.finkelshtein+AUR@gmail.com>
+
+pkgname=ipython-7
+pkgver=7.1.1
+pkgrel=1
+pkgdesc="IPython provides a rich toolkit to help you make the most of using Python interactively"
+url="https://ipython.readthedocs.io/en/stable/"
+arch=(any)
+license=('BSD')
+depends=(
+ 'python'
+ 'python-prompt_toolkit-2'
+ 'python-pygments'
+ 'python-traitlets'
+ 'python-pickleshare'
+ 'python-decorator'
+ 'python-jedi'
+)
+provides=('ipython' 'ipython-7')
+conflicts=('ipython')
+makedepends=('python-setuptools')
+source=("https://github.com/ipython/ipython/releases/download/$pkgver/ipython-$pkgver.tar.gz")
+md5sums=('4e1f459a7592101736d695751403bd4c')
+
+prepare() {
+ cp -a "${srcdir}/ipython-$pkgver" "${srcdir}/python-$pkgbase-$pkgver"
+}
+
+build() {
+ cd "${srcdir}/python-$pkgbase-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/python-$pkgbase-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+}
+