summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIru Cai2016-05-01 20:02:09 +0800
committerIru Cai2016-05-02 12:29:25 +0800
commit14322769a9758f9f3520fb8c56e2833575a189cd (patch)
tree09f51538af6a9705c3d13abb21b8ac1a6ffeef77 /PKGBUILD
parentde3c3637e0157f7ef67e10c838c34f464aff3aec (diff)
downloadaur-14322769a9758f9f3520fb8c56e2833575a189cd.tar.gz
fix the PNGImageDecoder compiling error
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b60815a15c5a..f84497a8663a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,11 +23,13 @@ options=('!strip')
source=(https://downloads.iridiumbrowser.de/source/iridium-browser-${pkgver}.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium.desktop
- chromium-widevine.patch)
+ chromium-widevine.patch
+ fix_PNGImageDecoder.patch)
sha256sums=('439de1a7819eb5c4ba2a2f82a8e226f27270f23b9c7a5cd452d994836b07b9b6'
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
- '4660344789c45c9b9e52cb6d86f7cb6edb297b39320d04f6947e5216d6e5f64c')
+ '4660344789c45c9b9e52cb6d86f7cb6edb297b39320d04f6947e5216d6e5f64c'
+ '42086dbe5c68744a6bed4e4af6035defbd6e1dfc1c3f32a4711c5c953f938698')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@@ -52,6 +54,8 @@ prepare() {
# https://code.google.com/p/chromium/issues/detail?id=541273
#sed -i "/'target_name': 'libvpx'/s/libvpx/&_new/" build/linux/unbundle/libvpx.gyp
+ patch -p0 -i ../fix_PNGImageDecoder.patch
+
# Enable support for the Widevine CDM plugin
# The actual libraries are not included, but can be copied over from Chrome:
# libwidevinecdmadapter.so