summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2024-04-21 17:49:41 +0000
committerxiota2024-04-21 17:50:52 +0000
commit45e6b175104de4c55092576acaea335f4d03d59b (patch)
treeb5c1194167ac6efccb091924b07ed11c2822e161 /PKGBUILD
parentf1c8dd06918cd9b5707780a252eb3fa9ceee73ec (diff)
downloadaur-iriunwebcam-bin.tar.gz
2.8.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 35 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97f819f19d3d..e8bdd4626e46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,43 @@
-# Maintainer: Barfin
+# Maintainer:
+# Contributor: Barfin
# Contributor: DanielH, agstrc
pkgname=iriunwebcam-bin
-pkgver=2.8.1
+pkgver=2.8.2
pkgrel=1
-pkgdesc="Use your phone's camera as a wireless webcam in your PC."
-arch=('any')
-url="http://iriun.gitlab.io"
-license=(unknown)
-source=("iriunwebcam-${pkgver}.deb::http://iriun.gitlab.io/iriunwebcam-${pkgver}.deb")
-options=('!strip')
-depends=('jack' 'qt5-base' 'v4l2loopback-dkms' 'android-tools')
+pkgdesc="Use your phone's camera as a wireless webcam in your PC"
+url="https://iriun.com/"
+license=('LicenseRef-Iriun')
+arch=('x86_64')
+
+source=(
+ "iriunwebcam-${pkgver}.deb::http://iriun.gitlab.io/iriunwebcam-${pkgver}.deb"
+ "LICENSE.iriun.txt" # extracted from mac archive
+)
+sha256sums=(
+ '1df7c6ce15cf7690f4b616f22ae80a01ea639007aae2a9a5394c86acdf007a04'
+ 'eb2ba875d0b419ab7d6327a933d619d1b9eed51f89d49e55ed789bf8f37f75be'
+)
package() {
- tar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
+ depends+=(
+ 'alsa-lib'
+ 'avahi'
+ 'qt5-base'
+ )
- # The permissions on the upstream file are wrong (eg: /etc is set to 775 instead of 755)
- # The command below sets directories to 755 but files to 644
- chmod -R u+rwX,go+rX,go-w "${pkgdir}"
- chmod 755 "${pkgdir}/usr/local/bin/iriunwebcam"
-}
+ tar -xf "$srcdir/data.tar.xz" -C "$pkgdir"
+
+ # move binary
+ install -Dm644 "$pkgdir/usr/local/bin/iriunwebcam" -t "$pkgdir/usr/bin/"
+ rm -rf "$pkgdir/usr/local"
-md5sums=('cbc479a48bb1bf8be7f9408360020a28')
+ # fix desktop
+ sed -E -e 's&/usr/local/bin/&&' -i "$pkgdir/usr/share/applications/iriunwebcam.desktop"
+
+ # license
+ install -Dm644 LICENSE.iriun.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
+
+ # fix permissions
+ chmod -R u+rwX,go+rX,go-w "$pkgdir"
+}