summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBeacon515L2016-05-21 18:42:32 +1000
committerBeacon515L2016-05-21 18:42:32 +1000
commit89d31a0d4d16ba3456cac9f6267a7975de2eed42 (patch)
tree924d08619a111a1362173a8ed9c2dbc5a2206ee8 /PKGBUILD
downloadaur-89d31a0d4d16ba3456cac9f6267a7975de2eed42.tar.gz
Initial and final commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90abd8366379
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Liam Greenough (beacon515@gmail.com)
+#Substantially adapted from the PKGBUILD of isl-git
+
+pkgname=isl15
+pkgver=0.15
+pkgrel=1
+pkgdesc="Library for manipulating sets and relations of integer points bounded by linear constraints"
+arch=('i686' 'x86_64')
+url="http://isl.gforge.inria.fr/"
+depends=('gmp')
+license=('MIT')
+options=('!libtool')
+provides=('isl')
+conflicts=('isl-git')
+source=('http://isl.gforge.inria.fr/isl-0.15.tar.gz')
+md5sums=('ca0e2d172ff0b57764b10867c8fc762f')
+
+build() {
+ cd isl-0.15
+# ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd isl-0.15
+ make check
+}
+
+package() {
+ cd isl-0.15
+ make -j1 DESTDIR="$pkgdir/" install
+
+ install -dm755 $pkgdir/usr/share/gdb/auto-load/usr/lib/
+ mv $pkgdir/{,/usr/share/gdb/auto-load/}usr/lib/libisl.so.15.0.0-gdb.py
+
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/isl/LICENSE
+}