summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHu Butui2023-06-22 23:07:47 +0800
committerHu Butui2023-06-22 23:07:47 +0800
commit0cc55db0f58b24f957308f8924378ec8677db5a4 (patch)
tree67e4c0d9082e8814f35c6d3f8a6829a5d74e9d68 /PKGBUILD
parent7621cfbee3b13d01dfd23862dcd9393ad16f395b (diff)
downloadaur-0cc55db0f58b24f957308f8924378ec8677db5a4.tar.gz
upgrade to 4.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31ac9e8e6735..bc7eb1e0aa6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,8 @@ _itkver=5.2.1
# _vtkver=9.1.0
_vtkver=9.2.6
pkgname=itk-snap
-pkgver=4.0.0
-pkgrel=2
+pkgver=4.0.1
+pkgrel=1
pkgdesc="A software application used to segment structures in 3D medical images"
arch=('x86_64')
url="https://www.itksnap.org"
@@ -20,8 +20,6 @@ license=('GPL')
depends=(
curl
expat
- gcc-libs
- gcc-libs
glibc
hdf5
libglvnd
@@ -37,14 +35,17 @@ makedepends=(
cmake
eigen
fftw
+ gcc12
gendesk
git
gtest
)
+# upstream did not create a git tag for 4.0.1
+# but according to the git log message, this commit should be release 4.0.1
source=(
"vtk-${_vtkver}.tar.gz::https://github.com/Kitware/VTK/archive/refs/tags/v${_vtkver}.tar.gz"
"itk-${_itkver}.tar.gz::https://github.com/InsightSoftwareConsortium/ITK/archive/refs/tags/v${_itkver}.tar.gz"
- "${pkgname}-${pkgver}::git+https://github.com/pyushkevich/itksnap.git#tag=v${pkgver}"
+ "${pkgname}-${pkgver}::git+https://github.com/pyushkevich/itksnap.git#commit=95a41ee3a84cb7f986df2f59cf1994a608ab980b"
)
sha512sums=('3ccb19cd98e691828e285d2d85aef890c4796d91588e02c401102feefb26c120f9d5195a79d1e7a04b037bf0bf0898b9791a341e0733d92234ca644e62da19b0'
'cccb64766acaebe49ee2dd8b82b7b5aaa6a35e97f2cc7738ad7f3cd65006b73b880ac59341cd640abd64c2ac665633f01504760071f5492e40aa97e7ba6db2a9'
@@ -52,6 +53,10 @@ sha512sums=('3ccb19cd98e691828e285d2d85aef890c4796d91588e02c401102feefb26c120f9d
)
prepare() {
+ # we need to build itk 5.2.1 with gcc 12, gcc 13 is not working
+ # we could just export these envs
+ export CC=gcc-12
+ export CXX=g++-12
echo "Creating desktop file"
gendesk -f -n --pkgname ${pkgname} \
--pkgdesc "${pkgdesc}" \