summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorblackhole2015-06-08 22:56:59 +0200
committerblackhole2015-06-08 22:56:59 +0200
commitbaab4642bb085e5f962d5240879ca533066ece0d (patch)
treec8177551bdb92c7727a81175cbeb72bf265e8acb /PKGBUILD
downloadaur-baab4642bb085e5f962d5240879ca533066ece0d.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..878b1f76cb1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: AudioLinux <audiolinux AT fastmail DOT fm>
+
+_pkgname=itop
+pkgname=$_pkgname-git
+pkgver=0.1.9.g6dbb3c4
+pkgrel=2
+pkgdesc="Interrupts 'top-like' utility for Linux"
+arch=('any')
+url="https://github.com/kargig/itop"
+license=('custom')
+depends=('perl')
+makedepends=('git')
+conlicts=('itop')
+source="git+https://github.com/kargig/itop.git"
+#source=("git://github.com/kargig/$pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g" | sed "1s/v//"
+}
+
+package() {
+ install -Dm755 "$srcdir/itop/itop" "$pkgdir/usr/bin/itop"
+ install -Dm644 "$srcdir/itop/LICENSE" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm644 "$srcdir/itop/README.md" "$pkgdir/usr/share/doc/$_pkgname/README.md"
+}