summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJiří Klimeš2019-06-14 13:16:44 +0200
committerJiří Klimeš2019-06-14 14:06:52 +0200
commita55fa7a046afcd06c30c19f13493f01e5051f1f1 (patch)
treeed9edc69022e206530e1477a8815034248d35d9a /PKGBUILD
parentb9eefe9fedce2ed8cdc14e429f56cc54cb6625ca (diff)
downloadaur-a55fa7a046afcd06c30c19f13493f01e5051f1f1.tar.gz
Enable building for Linux kernels 5.x
Adds a temporary patch for tecmake.mak. The patch will be removed when it is fixed upstream.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c18afb46afa7..f310082a2882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=iup
pkgname=('iup' 'lua-iup' 'lua51-iup' 'lua52-iup')
pkgver=3.26
-pkgrel=1
+pkgrel=2
pkgdesc="C cross platform GUI toolkit"
arch=('x86_64')
url="https://www.tecgraf.puc-rio.br/iup/"
@@ -28,10 +28,12 @@ makedepends=('lsb-release'
source=(
"https://downloads.sourceforge.net/project/iup/${pkgver}/Docs%20and%20Sources/iup-${pkgver}_Sources.tar.gz"
"https://downloads.sourceforge.net/project/iup/${pkgver}/Docs%20and%20Sources/iup-${pkgver}_Docs.pdf"
+ "tecmake-fix-Linux5-build.patch"
)
md5sums=('446668073d9a87c57f4e5d682b8663f4'
- '78341ce38463a168a2a14f59c58808f5')
+ '78341ce38463a168a2a14f59c58808f5'
+ '057b075a25ff818e8f928a85a739398c')
prepare() {
# Link iupview statically
@@ -44,6 +46,10 @@ prepare() {
# Add RUN_PATH variable to be able to set DT_RUNPATH
sed 's/$(ECHO)$(LINKER)/& $(RUN_PATH)/' -i "$srcdir"/iup/tecmake.mak
sed 's/$(ECHO)$(LD)/& $(RUN_PATH)/' -i "$srcdir"/iup/tecmake.mak
+
+ # patch for building for kernel 5.x
+ # temporary - until it is fixed in upstream
+ patch -p0 < "$srcdir"/tecmake-fix-Linux5-build.patch
}
_lua_iup_build_helper() {