summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBruno Santos2018-08-04 00:29:17 +0100
committerBruno Santos2018-08-06 00:48:13 +0100
commit42059b50e15cb788c6cffbdf4782f1a71e5d8f68 (patch)
tree72b3bcc360a0c5059a0a7ea2a570f63f062b92bf /PKGBUILD
downloadaur-42059b50e15cb788c6cffbdf4782f1a71e5d8f68.tar.gz
Initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae7203f29ed6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Bruno Santos <brunomanuelsantos@tecnico.ulisboa.pt>
+
+pkgname=ixxat-socketcan
+pkgver=1.1.148.0
+pkgrel=0
+pkgdesc="SocketCAN driver for IXXAT USB-to-CAN v2"
+arch=('i686' 'x86_64')
+url="https://www.ixxat.com/products/products-industrial/pc-interfaces/pc-can-interfaces/socketcan"
+license=('GPL2')
+makedepends=(linux-headers)
+optdepends=('can-utils: Linux-CAN / SocketCAN user space applications')
+install=$pkgname.install
+source=("https://www.ixxat.com/docs/librariesprovider8/default-document-library/downloads/other-drivers/socketcan.zip?sfvrsn=c486dcd6_22")
+md5sums=('c42d19b75802691b057a8163606903af')
+
+_extramodules=extramodules-$(uname -r | sed 's/\([0-9]*\.[0-9]*\).*/\1/')-arch
+
+build() {
+ make
+}
+
+package() {
+ mkdir -p $pkgdir/usr/lib/modules/$_extramodules
+ install usb-to-can_socketcan/ixx_usb.ko $pkgdir/usr/lib/modules/$_extramodules
+}