summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Husmann2015-07-08 18:29:45 +0200
committerStefan Husmann2015-07-08 18:29:45 +0200
commit9a668580d19cfcf856ad99c5f6175783d9fafe19 (patch)
treeec5d7a9403b2299bd59c6d7b94c4ee50010359a5 /PKGBUILD
downloadaur-9a668580d19cfcf856ad99c5f6175783d9fafe19.tar.gz
Initial Upload to AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a89986940251
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: perlawk
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=jacal
+pkgver=1c4
+pkgrel=1
+pkgdesc="Jacal is a symbolic mathematics system written in the programming language Scheme."
+url="http://people.csail.mit.edu/jaffer/JACAL.html"
+arch=('i686' 'x86_64')
+license=('LGPL')
+depends=('scm' 'slib')
+install=jacal.install
+source=(http://groups.csail.mit.edu/mac/ftpdir/scm/$pkgname-$pkgver.zip)
+md5sums=('58e03bd4292a02744728e6f68f48bb41')
+options=('!makeflags')
+
+build() {
+ export SCHEME_LIBRARY_PATH=/usr/lib/slib/
+ cd $srcdir/$pkgname
+
+ ./configure --prefix=/usr --exec-prefix=/usr
+ sed -i 's/jacal-$(VERSION).info/jacal.info/g;' Makefile
+
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname
+ make DESTDIR=$pkgdir install
+ rmdir $pkgdir/usr/share/doc/$pkgname
+}
+