summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Runge2018-08-24 01:28:22 +0200
committerDavid Runge2018-08-24 01:28:22 +0200
commit6f89de17140045765a43337a063e1c551e545787 (patch)
tree10cf2d3cfb50aadd968935c3b2ec696d4e3aad2f /PKGBUILD
parent141e083828b29feca7d24c48f6409e4a23564649 (diff)
downloadaur-6f89de17140045765a43337a063e1c551e545787.tar.gz
PKGBUILD: Adding epoch, to better follow tags upstream. Major cleanup of PKGBUILD, reflecting changes in [community], removing realtime settings (now taken care of in realtime-privileges optional dependency).
Adding a2jmidid as optional dependency.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD146
1 files changed, 44 insertions, 102 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88b78ffd1f0f..172f5bc33c3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,135 +1,77 @@
# Maintainer: rtfreedman (rob<d0t>til<d0t>freedman<aT>googlemail<d0t>com
+# Contributor: David Runge <dave@sleepmap.de>
# Contributor: Loren Copeland <thisisquitealongname at gm--l>
# based on jack2 PKGBUILD by Ray Rashif <schiv@archlinux.org>
+_name=jack2
pkgbase=jack2-git
pkgname=('jack2-git' 'jack2-dbus-git')
-#pkgname= # single build (overrides split)
-pkgver=3274
+pkgdesc="The next-generation JACK with SMP support"
+pkgver=1.9.12.r17.g21f67b38
pkgrel=1
-arch=('i686' 'x86_64')
+epoch=1
+arch=('x86_64')
url="http://jackaudio.org/"
-backup=(etc/security/limits.d/99-audio.conf)
license=('GPL')
+groups=('pro-audio')
makedepends=('python2' 'celt' 'opus' 'libsamplerate' 'git' 'libffado')
-source=("git+https://github.com/jackaudio/jack2"
- '99-audio.conf'
- '40-hpet-permissions.rules')
-md5sums=('SKIP'
- 'ae65b7c9ebe0fff6c918ba9d97ae342d'
- '471aad533ff56c5d3cbbf65ce32cadef')
+optdepends=('a2jmidid: Expose legacy ALSA sequencer applications in JACK MIDI'
+ 'realtime-privileges: Acquire realtime privileges')
+source=("${pkgname}::git+https://github.com/jackaudio/jack2")
+md5sums=('SKIP')
-_gitname='jack2'
-
-_pyfix() {
- sed -i 's:bin/env python:bin/env python2:' \
- "$pkgdir/usr/bin/jack_control"
-}
-
-_wafconf() {
- # default=64, kxstudio=256 --clients=
- # default=768, kxstudio=2048 --ports-per-application=
-
- python2 waf configure --prefix=/usr \
- --clients=128 --ports-per-application=1536 \
- --alsa --firewire $@
-
- # not building with doxygen
- # see https://github.com/jackaudio/jack2/issues/22
-}
-
-_isbuild() {
- printf "%s\n" ${pkgname[@]} | grep -qx $1
+prepare() {
+ cp -av ${pkgname[0]} ${pkgname[1]}
}
pkgver() {
- cd jack2
- # get a plain number
- echo $(git rev-list --count master)
-}
-
-prepare() {
- # we may do 2 different builds
- cp -r $_gitname $_gitname-dbus
+ cd ${pkgname[0]}
+ # get commits since last unannotated tag
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//g;'
}
build() {
- cd "$srcdir"
-
- # Some optimisation bug exists for current GCC
- # see http://gcc.gnu.org/bugzilla/show_bug.cgi?id=53663 ##fixed
- #export CFLAGS="${CFLAGS/-O[0-9]/-O0}"
- #export CFLAGS
- #export CXXFLAGS="$CFLAGS"
-
- # fix doxygen building
- # TODO: report upstream, but redundant until gihub issue 22 resolves
- #sed -i 's:build/default/html:html:' $_tarname-$pkgver/wscript
-
- # mixed dbus/classic build
- if _isbuild jack2-git; then
- cd $_gitname
- msg2 "Running Mixed D-Bus/Classic build"
- _wafconf --classic --dbus # --autostart=dbus|none|default|classic
- python2 waf build $MAKEFLAGS
- cd ..
- fi
+ cd ${pkgname[0]}
+ # configure jack2
+ python2 waf configure --prefix=/usr \
+ --htmldir="/usr/share/doc/${pkgbase}/" \
+ --freebob=no \
+ --classic \
+ --dbus
- # dbus-ONLY build
- if _isbuild jack2-dbus-git; then
- cd $_gitname-dbus
- msg2 "Running D-Bus-only build"
- _wafconf --dbus --autostart=dbus
- python2 waf build $MAKEFLAGS
- cd ..
- fi
+ # configure jack2-dbus
+ cd "${srcdir}/${pkgname[1]}"
+ python2 waf configure --prefix=/usr \
+ --htmldir="/usr/share/doc/${pkgbase}/" \
+ --freebob=no \
+ --dbus
+
+ # build jack2
+ cd "${srcdir}/${pkgname[0]}"
+ python2 waf build
+ # build jack2-dbus
+ cd "${srcdir}/${pkgname[1]}"
+ python2 waf build
}
package_jack2-git() {
- ! _isbuild jack2-git && return 0
-
- pkgdesc="The next-generation JACK with SMP support"
- depends=('libsamplerate' 'opus' 'celt' 'libffado')
- optdepends=('python2: jack_control')
- conflicts=('jack')
- provides=('jack' 'jack2')
-
- cd "$srcdir/$_gitname"
+ pkgdesc="JACK low-latency audio server for multi-processor machines (daemon activation)"
+ depends=('celt' 'libffado' 'opus' 'python-dbus')
+ conflicts=('jack' 'jack2-dbus')
+ provides=('jack')
+ cd ${pkgname}
python2 waf install --destdir="$pkgdir"
-
- # fix for major python transition
- _pyfix
-
- # configure realtime access/scheduling
- # see https://bugs.archlinux.org/task/26343
- install -Dm644 "$srcdir/99-audio.conf" \
- "$pkgdir/etc/security/limits.d/99-audio.conf"
-
- install -Dm644 "$srcdir/40-hpet-permissions.rules" \
- "$pkgdir/usr/lib/udev/rules.d/40-hpet-permissions.rules"
}
package_jack2-dbus-git() {
- ! _isbuild jack2-dbus-git && return 0
-
- pkgdesc="The next-generation JACK with SMP support (for D-BUS interaction only)"
- depends=('libsamplerate' 'celt' 'opus' 'libffado')
- optdepends=('python2: jack_control')
+ pkgdesc="JACK low-latency audio server for multi-processor machines (only dbus activation)"
+ depends=('celt' 'libffado' 'opus' 'python-dbus')
conflicts=('jack' 'jack2')
provides=('jack' 'jack2')
- cd "$srcdir/$_gitname-dbus"
-
+ cd ${pkgname}
python2 waf install --destdir="$pkgdir"
-
- _pyfix
-
- install -Dm644 "$srcdir/99-audio.conf" \
- "$pkgdir/etc/security/limits.d/99-audio.conf"
-
- install -Dm644 "$srcdir/40-hpet-permissions.rules" \
- "$pkgdir/usr/lib/udev/rules.d/40-hpet-permissions.rules"
}
# vim:set ts=2 sw=2 et: