summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Runge2019-08-31 03:46:07 +0200
committerDavid Runge2019-08-31 03:46:07 +0200
commitb69edd5d2399aa32fa1749a690e8adef8ab75a92 (patch)
tree1200113a82f46db4f39d055f735c9a8df63a6d7f /PKGBUILD
parent32764702cf717190a97d5b3503c237e2630d48b1 (diff)
downloadaur-b69edd5d2399aa32fa1749a690e8adef8ab75a92.tar.gz
PKGBUILD: Removing jack2-dbus-git (it's included in jack2-git). Moving custom waf scripts to dedicated locations, so they can be picked up by system waf. Adding libjack.so, libjacknet.so and libjackserver.so to provides. Removing python from makedepends and adding waf instead. Switching to correct licenses (GPL2 and LGPL2.1). Adding python-dbus to optdepends (for jack_control).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD87
1 files changed, 38 insertions, 49 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3dfbe2ca202..2323f99c1660 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,77 +1,66 @@
-# Maintainer: rtfreedman (rob<d0t>til<d0t>freedman<aT>googlemail<d0t>com
-# Contributor: David Runge <dave@sleepmap.de>
+# Maintainer: David Runge <dave@sleepmap.de>
+# Contributor: rtfreedman (rob<d0t>til<d0t>freedman<aT>googlemail<d0t>com
# Contributor: Loren Copeland <thisisquitealongname at gm--l>
-# based on jack2 PKGBUILD by Ray Rashif <schiv@archlinux.org>
_name=jack2
-pkgbase=jack2-git
-pkgname=('jack2-git' 'jack2-dbus-git')
-pkgdesc="The next-generation JACK with SMP support"
-pkgver=1.9.12.r119.g82329969
+pkgname=jack2-git
+pkgdesc="C++ version of the JACK low-latency audio server for multi-processor machines"
+pkgver=1.9.12.r178.g77de2e33
pkgrel=1
epoch=1
arch=('x86_64')
url="http://jackaudio.org/"
-license=('GPL2' 'GPL3')
+license=('GPL2' 'LGPL2.1')
groups=('pro-audio')
-makedepends=('python' 'celt' 'opus' 'libsamplerate' 'git' 'libffado')
+depends=('celt' 'opus' 'libsamplerate')
+makedepends=('git' 'libffado' 'portaudio' 'waf')
optdepends=('a2jmidid: Expose legacy ALSA sequencer applications in JACK MIDI'
'libffado: Firewire support'
'portaudio: Portaudio support'
+ 'python-dbus: For jack_control'
'realtime-privileges: Acquire realtime privileges')
-source=("${pkgname}::git+https://github.com/jackaudio/jack2")
+provides=('jack' 'libjack.so' 'libjacknet.so' 'libjackserver.so')
+conflicts=('jack' 'jack2')
+replaces=('jack2-dbus-git')
+source=("${pkgname}::git+https://github.com/jackaudio/${_name}")
md5sums=('SKIP')
prepare() {
- cp -av ${pkgname[0]} ${pkgname[1]}
+ cd "${pkgname}"
+ # copying relevant custom waf scripts and loading them specifically using
+ # wscript
+ (
+ touch __init__.py
+ mkdir -vp tools
+ cp -v waflib/extras/xcode*.py tools
+ mv -v autooptions/__init__.py tools/autooptions.py
+ rm -rv waflib
+ sed -e "s/load('xcode'/load('xcode', tooldir='tools'/g" \
+ -e "s/load('xcode6'/load('xcode6', tooldir='tools'/g" \
+ -e "s/load('autooptions'/load('autooptions', tooldir='tools'/g" \
+ -i wscript
+
+ )
}
pkgver() {
- cd ${pkgname[0]}
+ cd "${pkgname}"
# get commits since last unannotated tag
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//g;'
}
build() {
- cd ${pkgname[0]}
- # configure jack2
- python waf configure --prefix=/usr \
- --htmldir="/usr/share/doc/${pkgbase}/" \
- --classic \
- --dbus
-
- # configure jack2-dbus
- cd "${srcdir}/${pkgname[1]}"
- python waf configure --prefix=/usr \
- --htmldir="/usr/share/doc/${pkgbase}/" \
- --dbus
-
- # build jack2
- cd "${srcdir}/${pkgname[0]}"
- python waf build
- # build jack2-dbus
- cd "${srcdir}/${pkgname[1]}"
- python waf build
+ cd "${pkgname}"
+ waf configure --prefix=/usr \
+ --htmldir="/usr/share/doc/${pkgbase}/" \
+ --classic \
+ --dbus
+ waf build
}
-package_jack2-git() {
- pkgdesc="JACK low-latency audio server for multi-processor machines (daemon activation)"
- depends=('celt' 'opus' 'libsamplerate' 'python-dbus')
- conflicts=('jack' 'jack2-dbus')
- provides=('jack')
-
- cd ${pkgname}
- python waf install --destdir="$pkgdir"
-}
-
-package_jack2-dbus-git() {
- pkgdesc="JACK low-latency audio server for multi-processor machines (only dbus activation)"
- depends=('celt' 'opus' 'libsamplerate' 'python-dbus')
- conflicts=('jack' 'jack2')
- provides=('jack' 'jack2')
-
- cd ${pkgname}
- python waf install --destdir="$pkgdir"
+package() {
+ cd "${pkgname}"
+ waf install --destdir="$pkgdir"
}
# vim:set ts=2 sw=2 et: