summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2020-10-19 17:59:31 +0200
committerChristopher Arndt2020-10-19 17:59:31 +0200
commitbd2e2ae75c971c3b115c6d6d60933785d5208570 (patch)
tree91d0a91a639d0f4e3b560e70faa827174a8f0932 /PKGBUILD
parentce8e81c81ce14ce0f84ac4e6b9ddd33501d461a2 (diff)
downloadaur-bd2e2ae75c971c3b115c6d6d60933785d5208570.tar.gz
Add versioned provides
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de8c9e4798b5..83e11a29c382 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: rtfreedman (rob<d0t>til<d0t>freedman<aT>googlemail<d0t>com
# Contributor: Loren Copeland <thisisquitealongname at gm--l>
-_name=jack2
+_pkgname=jack2
pkgname=jack2-git
pkgdesc="C++ version of the JACK low-latency audio server for multi-processor machines"
pkgver=1.9.16.r0.g5b78c2ef
@@ -22,10 +22,12 @@ optdepends=('a2jmidid: Expose legacy ALSA sequencer applications in JACK MIDI'
'python-dbus: For jack_control'
'realtime-privileges: Acquire realtime privileges'
'zita-ajbridge: for using multiple ALSA devices')
-provides=('jack' 'jack2' 'libjack.so' 'libjacknet.so' 'libjackserver.so')
-conflicts=('jack' 'jack2')
+provides=('jack' "jack=${pkgver//.r*}"
+ "${_pkgname}" "${_pkgname}=${pkgver//.r*}"
+ 'libjack.so' 'libjacknet.so' 'libjackserver.so')
+conflicts=('jack' "${_pkgname}")
replaces=('jack2-dbus-git')
-source=("${pkgname}::git+https://github.com/jackaudio/${_name}#branch=master")
+source=("${pkgname}::git+https://github.com/jackaudio/${_pkgname}#branch=master")
md5sums=('SKIP')
prepare() {