summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2017-02-04 16:49:50 +0100
committerChristopher Arndt2017-02-04 16:49:50 +0100
commitfe5a970f4ee61bbcbc160097d0d8189a3821dfcf (patch)
tree9dd11a7f798d3b89bf85b0231fcb6e880de17c22 /PKGBUILD
parent8e491f8c9bee202e8c5ceedb87ffebaa7faf0194 (diff)
downloadaur-fe5a970f4ee61bbcbc160097d0d8189a3821dfcf.tar.gz
Use steinberg-vst36 AUR package in makedepends instead of including VST3 SDK in sources
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4954716da1be..990c70331715 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,17 @@ _pkgname=jackass
pkgname="${_pkgname}-git"
pkgver=1.0.r13.adcd7eb
_pkgver=1.0
-pkgrel=2
+pkgrel=3
pkgdesc="A VST plugin that provides JACK-MIDI support for VST hosts."
arch=('i686' 'x86_64')
url="https://github.com/falkTX/JackAss/"
license=('MIT')
depends=('gcc-libs-multilib' 'wine')
-makedepends=('git')
+makedepends=('git' 'steinberg-vst36')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("${_pkgname}::git+https://github.com/falkTX/JackAss.git"
- 'http://www.steinberg.net/sdk_downloads/vstsdk360_22_11_2013_build_100.zip')
-sha256sums=('SKIP'
- '74e41da563a1c91e86677530936cb46a15f1af76b29d4c1877134cf29eafb718')
+source=("${_pkgname}::git+https://github.com/falkTX/JackAss.git")
+sha256sums=('SKIP')
changelog=ChangeLog
@@ -29,7 +27,8 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- make CXXFLAGS="-I ${srcdir}/VST3\\ SDK" linux wine32 wine64
+ sed -i -e 's|public\.sdk/source/vst2\.x/|vst36/|' JackAss.cpp
+ make linux wine32 wine64
}
package() {