summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Loitsch2023-05-20 14:47:46 +0200
committerFlorian Loitsch2023-05-20 14:47:46 +0200
commite0d687d0cf37947c3121df8b87e59b7133f6c293 (patch)
tree91635607b709525943835d2f90883cb5c04fc418 /PKGBUILD
downloadaur-e0d687d0cf37947c3121df8b87e59b7133f6c293.tar.gz
Initial release
Only builds the 'jag' executable. Jaguar will still download precompiled executables when running `jag setup`.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10a9d4b9a5e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Florian Loitsch <florian@toit.io>
+pkgname=jaguar
+pkgver=1.9.22
+pkgrel=1
+pkgdesc="Tool to develop Toit programs for the ESP32"
+arch=('x86_64')
+url="https://github.com/toitlang/jaguar"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('go')
+source=("$pkgname-$pkgver.tar.gz"::"https://github.com/toitlang/jaguar/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('6a5f63e6e0d21bae7aef5ee20664f22ac7fc887e8bd47bfb7a8ed00311d25597')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make jag
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D build/jag -t "$pkgdir/usr/bin/"
+}