summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Otto2019-12-17 15:04:33 +0100
committerDavid Otto2019-12-17 15:04:33 +0100
commitab46b06ed0bf3aed70fb2497366ced5411578476 (patch)
tree544e4f27c4370c83702c7a2a3831ef589c6a17ed /PKGBUILD
downloadaur-ab46b06ed0bf3aed70fb2497366ced5411578476.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a18b29885687
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=japi-compliance-checker
+pkgver=2.4
+pkgrel=1
+pkgdesc="A tool for checking backward API/ABI compatibility of a Java library"
+url="https://lvc.github.io/japi-compliance-checker/"
+arch=('any')
+license=('LGPL')
+depends=('perl' 'java-environment')
+
+source=("https://github.com/lvc/japi-compliance-checker/archive/${pkgver}.tar.gz")
+sha256sums=('0fd8ff8539a6f4a2c30379999befc1f9003fbb513f778b018a722360ab8c2229')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install prefix="${pkgdir}/usr/"
+}
+