summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-05-21 14:54:45 +0800
committerzxp198210052023-05-21 14:54:45 +0800
commitbf7011feeacffb5168ec636b71567935cc2e3aae (patch)
treeb9c09e4cb0b5c6ea4ae3b8172ee1dc575073979c /PKGBUILD
downloadaur-bf7011feeacffb5168ec636b71567935cc2e3aae.tar.gz
first release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b35e170a68bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="japreader-bin"
+pkgver=1.8.2
+pkgrel=1
+pkgdesc="An Electron app that helps you read Japanese text."
+arch=('x86_64')
+url="https://github.com/marisukukise/japReader"
+license=('GPL3')
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}-appimage")
+depends=('glibc' 'libcups' 'mesa' 'dbus' 'libxfixes' 'libx11' 'pango' 'cairo' 'libdrm' 'libxkbcommon' 'nodejs' \
+ 'nspr' 'libxext' 'at-spi2-core' 'glib2' 'alsa-lib' 'gtk3' 'libxrandr' 'expat' 'libxdamage' 'libxcb' 'gcc-libs' \
+ 'libxcomposite' 'nss')
+options=(!strip)
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb")
+sha256sums=('09e3b7a7a374139371925d777951fe6c756f97fded82568c35f3c9a8381ee756')
+
+package() {
+ bsdtar -xf "${srcdir}/data.tar.zst"
+ install -Dm755 -d "${pkgdir}/opt" "${pkgdir}/usr"
+ cp -r "${srcdir}/usr/lib/"* "${pkgdir}/opt"
+ cp -r "${srcdir}/usr/share" "${pkgdir}/usr"
+ sed 's|Exec=japreader|Exec=/opt/japreader/japreader|g' -i "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+} \ No newline at end of file