summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorparazyd2016-01-21 10:56:03 +0100
committerparazyd2016-01-21 10:56:03 +0100
commit2d22540172e554ae385b7b01d1eee41a7f8922c8 (patch)
tree7c0b455043aaeee92fc3a049ab7e3363a0b0c44f /PKGBUILD
parent7dd9f359395fd139a2ecc0ce43706ea627ac3c98 (diff)
downloadaur-2d22540172e554ae385b7b01d1eee41a7f8922c8.tar.gz
Added patch to remove libgnome-keyring related code on build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b4b828dfeb8..0b7c990d89c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,21 @@
_name=JaroMail
pkgname=jaromail-git
pkgver=4.1
-pkgrel=1
+pkgrel=2
pkgdesc="A commandline tool to easily and privately handle your e-mail, git version"
arch=('x86_64' 'i686')
url="https://www.dyne.org/software/jaro-mail"
license=('GPL3')
-depends=('zsh' 'mutt' 'libgnome-keyring' 'fetchmail' 'vim' 'msmtp' 'notmuch' 'abook' 'elinks' 'pinentry' 'wipe' 'alot')
+depends=('zsh' 'mutt' 'fetchmail' 'vim' 'msmtp' 'notmuch' 'abook' 'elinks' 'pinentry' 'wipe' 'alot')
makedepends=('gcc' 'glib2')
-source=("git://github.com/dyne/JaroMail")
-sha256sums=("SKIP")
+source=("git://github.com/dyne/JaroMail"
+ "00-remove-libgnome-keyring.patch")
+sha256sums=("SKIP"
+ "3fa439b8ae02c33005a004c45f246e43fa3642c3eb2540c40ad31975e5ecd2a9")
+
+prepare() {
+ patch "$_name/build/build-gnu.sh" "00-remove-libgnome-keyring.patch"
+}
build() {
cd "$_name"