summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZach Callear2018-04-25 10:19:15 -0600
committerZach Callear2018-04-25 10:19:15 -0600
commitba6097a7abe80c22793fef9884703fd9a93ec44e (patch)
tree17feef55b8bf0fa7d425facff3c992573e126e27 /PKGBUILD
parent07c097567b99a3c1f09f10494f95495803778a53 (diff)
downloadaur-ba6097a7abe80c22793fef9884703fd9a93ec44e.tar.gz
Explicitly require OpenJDK 7 for build
Although this can build on OpenJDK 8, specifying that with java-environment and limiting the version still results in the user getting a prompt to pick the specific version they want. Requiring specifically OpenJDK 7, as the official package does, makes it much more foolproof for the user.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab456a4b27cb..21ebf180ffad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,11 +18,11 @@ _jdk_update=172
_jdk_build=11
pkgver=${_java_ver}.u${_jdk_update}
_repo_ver=jdk${_java_ver}u${_jdk_update}-b${_jdk_build}
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'i686')
url='http://openjdk.java.net/'
license=('custom')
-makedepends=('java-environment>=7' 'java-environment<9' 'ccache' 'cpio' 'unzip' 'zip'
+makedepends=('jdk7-openjdk' 'ccache' 'cpio' 'unzip' 'zip'
'libxrender' 'libxtst' 'fontconfig' 'libcups' 'alsa-lib')
_url_src=http://hg.openjdk.java.net/jdk8u/jdk8u
source=(jdk8u-${_repo_ver}.tar.gz::${_url_src}/archive/${_repo_ver}.tar.gz