summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Hillenbrand2023-07-11 21:08:24 -0400
committerChristopher Hillenbrand2023-07-11 21:08:24 -0400
commiteeec3f8b5659cdec30a92b3c5cd935291d0dc2b6 (patch)
tree8b139891a52990c6eccf2a2ada46b4e8298c0f6f /PKGBUILD
parenta045f7ec1e571d82f8d93971a4589972e245cd45 (diff)
downloadaur-jbig2enc.tar.gz
Add commit ea05019 -- fix build with Leptonica >=1.83
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e682dd0d99c7..1f7070930a0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=jbig2enc
pkgver=0.29
-pkgrel=4
+pkgrel=5
pkgdesc="A JBIG2 image encoder"
arch=('i686' 'x86_64')
url="https://github.com/agl/jbig2enc"
@@ -18,22 +18,22 @@ changelog=CHANGELOG
source=("https://github.com/agl/jbig2enc/archive/refs/tags/$pkgver.tar.gz"
"jbig2enc-pdfpy.patch"
"jbig2enc.1"
- "commit-ea6a40a.patch"
+ "commit-ea0501904.patch"
"dpi.patch")
sha256sums=('bfcf0d0448ee36046af6c776c7271cd5a644855723f0a832d1c0db4de3c21280'
'a5d98fc43b2f3dc73dd1f352a439a6ae73fd085f469420aa29e47d9a4e2f40f6'
'c940124f102695872fae02b243e0dd99c05ecfb3ecef0a476b3e903a0db69a54'
- '99d086e922653cc6fa0b1cccff90f9fd1d279ecd96104e73ea281c253781718a'
+ 'c2f1c825346f38747f8c85a2020b78922cc964052d78cafd7673ec456acd9dae'
'5cccc44d3019367351516cc3952692fbe23bc05b7c5726553f98d5b262f78686')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
#sed -i 's@^#!/usr/bin/python$@#!/usr/bin/env python2@' pdf.py
- patch --forward --strip=1 --input="${srcdir}/commit-ea6a40a.patch"
+ patch --forward --strip=1 --input="${srcdir}/commit-ea0501904.patch"
patch --forward --strip=1 --input="${srcdir}/jbig2enc-pdfpy.patch"
patch --forward --strip=1 --input="${srcdir}/dpi.patch"
- cat "${srcdir}/jbig2enc.1" | gzip > "${srcdir}/jbig2enc.1.gz"
+ gzip -c "${srcdir}/jbig2enc.1" > "${srcdir}/jbig2enc.1.gz"
}
build() {