summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher2022-02-18 19:07:13 -0500
committerChristopher2022-02-18 19:07:13 -0500
commitdf7d939c2e057628e9c5844069534c88eebea3d3 (patch)
tree924adf68034faf1c246969922f31de09e0964c7f /PKGBUILD
parentf9b5214588d323878aeb3a7aefbe5bc8b51d40dc (diff)
downloadaur-df7d939c2e057628e9c5844069534c88eebea3d3.tar.gz
Added a man page based on doc/jbig2enc.html
Patched pdf.py to use python 3; removed python 2 as optional dependency Added automake, libtool, and gzip (for man page) as makedepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 22 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f8bbb34c3a0..2407950a7849 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,32 @@
-# Maintainer: Vianney le Clément <vleclement AT gmail·com>
+# Maintainer: Christopher Hillenbrand <chillenb dot lists at gmail dot com>
+# Contributor: Doron Behar <doron dot behar at gmail dot com>
+# Contributor: Vianney le Clément <vleclement at gmail dot com>
+
pkgname=jbig2enc
pkgver=0.29
-pkgrel=1
+pkgrel=2
pkgdesc="A JBIG2 image encoder"
arch=('i686' 'x86_64')
url="https://github.com/agl/jbig2enc"
license=('Apache')
depends=('gcc-libs' 'leptonica>=1.68' 'libpng' 'libjpeg' 'libtiff')
-optdepends=('python2: for pdf.py')
-source=("https://github.com/agl/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('c3d1f7fd51e272301d5de436afb1fccb')
+optdepends=('python: for pdf.py')
+provides=('jbig2enc')
+conflicts=('jbig2enc-git')
+makedepends=('automake' 'libtool' 'gzip')
+source=("https://github.com/agl/jbig2enc/archive/refs/tags/$pkgver.tar.gz"
+ "jbig2enc-pdfpy.patch"
+ "jbig2enc.1")
+sha256sums=('bfcf0d0448ee36046af6c776c7271cd5a644855723f0a832d1c0db4de3c21280'
+ '2614e02f9cc71d9b186ffaecf6abb4b270ad9ce43cb4d6284e9e96c4e4a44d06'
+ 'c940124f102695872fae02b243e0dd99c05ecfb3ecef0a476b3e903a0db69a54')
+
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- sed -i 's@^#!/usr/bin/python$@#!/usr/bin/env python2@' pdf.py
+ #sed -i 's@^#!/usr/bin/python$@#!/usr/bin/env python2@' pdf.py
+ patch --forward --strip=1 --input="${srcdir}/jbig2enc-pdfpy.patch"
+ cat "${srcdir}/jbig2enc.1" | gzip > "${srcdir}/jbig2enc.1.gz"
}
build() {
@@ -26,4 +39,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make install DESTDIR="$pkgdir"
+ install -dm755 "$pkgdir/usr/share/man/man1"
+ install -m644 "${srcdir}/jbig2enc.1.gz" "$pkgdir/usr/share/man/man1"
}
+