summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJeffrey E. Bedard2015-11-08 01:50:13 -0500
committerJeffrey E. Bedard2015-11-08 01:50:13 -0500
commit7f46d18d62acc0e8f9e58d54adee8c26cf1c5b5e (patch)
tree74e4811cb5ad450e51e0185b4167212db3399402 /PKGBUILD
downloadaur-7f46d18d62acc0e8f9e58d54adee8c26cf1c5b5e.tar.gz
Initial revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b0108a58bfc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Jeffrey E. Bedard <jefbed@gmail.com>
+pkgname=jbwm
+pkgver=1.35
+pkgrel=1
+epoch=
+pkgdesc="Simple X window manager"
+arch=('x86_64' 'x86')
+url="https://github.com/jefbed/jbwm"
+license=('MIT')
+groups=()
+depends=('libxau' 'libx11')
+makedepends=()
+checkdepends=()
+optdepends=()
+options=()
+install=
+changelog=
+source=( "https://github.com/jefbed/jbwm/archive/$pkgver.tar.gz" )
+noextract=()
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+# Unimplemented
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p $pkgdir/usr/bin
+ make DESTDIR="$pkgdir" install
+}
+md5sums=('b69a6b01a59420f120373e2f5b0e0a67')