summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDet2017-06-23 09:39:05 +0300
committerDet2017-06-23 09:39:05 +0300
commitf0274ff55cde68f90dbdf1a60b4cd4f007287954 (patch)
treeaef2537b8dfd855ef65135195c3610d4bd185ddc /PKGBUILD
parent771d12b9dd45b324b188ca606747505832c49fd1 (diff)
downloadaur-f0274ff55cde68f90dbdf1a60b4cd4f007287954.tar.gz
pkgdescs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1262fa2de673..76eca8aee00f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,6 @@ _minor=131
_build=b11
pkgver=${_major}u${_minor}
pkgrel=1
-pkgdesc="Documentation for Oracle Java Development Kit"
arch=('any')
url="http://www.oracle.com/technetwork/java/javase/downloads/index.html"
license=('custom:Oracle')
@@ -16,8 +15,8 @@ optdepends=("java-environment>=$_major: Compile and run examples")
options=('!strip')
source=("http://download.oracle.com/otn-pub/java/jdk/$pkgver-$_build/d54c1d3a095b4ff2b6607d096fa80163/jdk-$pkgver-docs-all.zip"
"http://download.oracle.com/otn-pub/java/javafx/$_major.0.$_minor-$_build/d54c1d3a095b4ff2b6607d096fa80163/javafx-$pkgver-apidocs.zip"
- 'LICENSE-Documentation'
- 'LICENSE-Oracle-Legal-Notices')
+ 'LICENSE-Documentation.txt'
+ 'LICENSE-Oracle-Legal-Notices.txt')
md5sums=('32df9c95f67e2983fdb4f3e722442d54'
'9ae377f4a4fce58a5fe959c01b3614bd'
'4d54057ca75b691366977dab2277e869'
@@ -26,19 +25,23 @@ md5sums=('32df9c95f67e2983fdb4f3e722442d54'
DLAGENTS=('http::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -b oraclelicense=a -o %o %u')
package_jdk-docs() {
+ pkgdesc="Documentation for Oracle Java Development Kit"
+
# Install
install -d "$pkgdir"/usr/share/doc/java/
mv docs/* "$pkgdir"/usr/share/doc/java/
# License
- install -Dm644 LICENSE-Documentation "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 LICENSE-Documentation.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
package_javafx-docs() {
+ pkgdesc="Documentation for Oracle JavaFX Development Kit"
+
# Install
install -d "$pkgdir"/usr/share/doc/java/javafx/
mv api "$pkgdir"/usr/share/doc/java/javafx/
# License
- install -Dm644 LICENSE-Oracle-Legal-Notices "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 LICENSE-Oracle-Legal-Notices.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}