summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Werkmeister2019-11-25 00:02:33 +0100
committerLucas Werkmeister2019-11-25 00:02:33 +0100
commitda7f4613c098290a487127869aa814ace8a3ba61 (patch)
tree2513859f65181a8f6276692b5578e45bbc2807ce /PKGBUILD
downloadaur-da7f4613c098290a487127869aa814ace8a3ba61.tar.gz
Initial commit
With the 19.3.0 release, GraalVM supports two Java versions: Java 8 and Java 11. Accordingly, the former graal-bin package is split into two: jdk8-graalvm-bin (this package) and jdk11-graalvm-bin. We use this opportunity to make several other adjustments as well. The main product name seems to be “GraalVM”, not just “Graal”, so we reflect this in the package name and in the Java name. For backwards compatibility, if we detect the user’s default Java was java-8-graal, we set it to this package’s java-8-graalvm instead. We no longer provide a version of the package name without the “-bin” suffix. It doesn’t seem likely that a built-from-source version will be added to the AUR soon, and other packages like jdk8-openj9-bin or jdk8-j9-bin don’t provide non-bin versions either. We no longer recommend a native-image package. The old package only did this because it used to include that functionality; this new package has never included native-image, so I don’t see the need to recommend it. People interested in it should be able to find it easily enough. A test script is included, which I’d been using locally for some time already. It assumes you’ve locally installed current versions of the GraalVM, FastR, TruffleRuby, GraalPython and native-image packages, and is typically run just before pushing the updated PKGBUILDs to the AUR. And finally, a .gitignore file never hurts.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e8b7b0e1dff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
+
+java_=8
+pkgname="jdk${java_}-graalvm-bin"
+pkgver=19.3.0
+pkgrel=1
+pkgdesc="Universal virtual machine for running applications written in a variety of languages (JVM-based, LLVM-based, or other), Java ${java_} version"
+arch=('x86_64')
+url='https://www.graalvm.org/'
+license=('custom')
+depends=('java-runtime-common'
+ 'java-environment-common')
+makedepends=()
+provides=("java-runtime=${java_}"
+ "java-environment=${java_}")
+install="$pkgname.install"
+source=("https://github.com/graalvm/graalvm-ce-builds/releases/download/vm-${pkgver}/graalvm-ce-java${java_}-linux-amd64-${pkgver}.tar.gz")
+sha256sums=('4442d3dfade1175f6905106757929113f1e74bc5c50156dc6a70c04759ac2660')
+
+package() {
+ cd "graalvm-ce-java${java_}-${pkgver}"
+ mkdir -p "$pkgdir/usr/lib/jvm/java-${java_}-graalvm/"
+ cp -a -t "$pkgdir/usr/lib/jvm/java-${java_}-graalvm/" *
+ install -DTm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}