summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPierre Mavro2023-10-02 15:44:15 +0200
committerPierre Mavro2023-10-02 15:45:35 +0200
commit456717fbc07573dbebb4d8aa6e15772371454eab (patch)
treef29d5a03bd8ff5689b96ccafcaf6cdd3785414dc /PKGBUILD
parent6cfb4d2ecdd99a22f9399dd12141654abe0b22fe (diff)
downloadaur-456717fbc07573dbebb4d8aa6e15772371454eab.tar.gz
feat: v2.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db7ef6574fc1..81281e67c2dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,22 @@
# Maintainer: Pierre Mavro <deimosfr@gmail.com>
pkgname=jeedom-status
-pkgver=1.0.4
+pkgver=2.0.0
pkgrel=1
pkgdesc="Add Jeedom global status to your favorite desktop bar (i3blocks, polybar, etc...)"
arch=(x86_64)
url="https://github.com/deimosfr/jeedom-status"
license=('GPL')
-makedepends=(git go)
+makedepends=(git cargo)
source=("https://github.com/deimosfr/jeedom-status/archive/v$pkgver.tar.gz")
build() {
cd "$pkgname-$pkgver"
- export CGO_LDFLAGS="${LDFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
- go build -o jeedom-status main.go
+ cargo build --release
}
package() {
cd "$pkgname-$pkgver"
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
}
-md5sums=('49117a156f7eaefd1a2ae3a0e8d18e46')
+sha256sums=('f6eca707b50ed0700edb9b4991137e7a96b1ebf0966ee2ae46fce39fffa6e8f5')